V4.2.2 bltouch firmware for Ender 5 pro, no Z offset, incorrect home



  • Hi

    So I went ahead and installed the latest Creality firmware from here:
    V4.2.2-Ender-5 Pro-32bit Mainboard-Marlin2.0.1-V1.3.1-BLTouch.bin

    Installed the BLtouch as shown here in the Creality video:
    Ender-5 BL touch installation tutorial

    and went to auto home (2:24) which the ender did but to X=70, Y=107, Z=10 not the centre of a 220/220 bed...

    How do I change this to the center?

    I then went to do the Z-offset as shown (2:35-3:14) but there is no way to set the z-offset under Control>motion (or anywhere else)

    How do I set this?

    Have tried several other firmware version but none seem to solve the problem does anyone have an answer to this, please.



  • Ok so still Zero answers from Creality.
    After searching around it looks like Creality have changed some of their boards but haven't bothered to update any of their firmware menus, help info, videos or actually tell anyone (TH3D have written a blog post on it).
    They seemed to have created a hellish nightmare to use the BLTouch by simply removing the Z-Offset option from the menu

    Oh! and Pronterface does not work as you cant save to the Eeprom any more.

    BUT

    Initial test of @davidzohar way of doing it seems to be working so I have expanded on it.

    NOTE: Make a note of any Step settings as they will get wiped

    1. Update to the latest firmware from Creality for your BLtouch setup.
    2. MAKE SURE YOUR SD CARD IS IN AT ALL TIMES WHEN YOU SWITCH ON AND OFF (thanks @davidzohar ) once the printer has booted it seems ok to remove the card and put it back in.
      "Also, one thing that drove me nuts was that if you don't keep the SD card in the SD card slot your settings will be gone if you turn the printer off. So make sure that your SD card is in all the time, during settings and during print..."
    3. Unwind all you bed level screws (so the bed is highest.
    4. Prepare > Auto home (this should result in X=70, Y=107, Z=10)
    5. Work out your Z-Offset (mine was about -2.6)

    Go to Prepare > Move > Move Z-Axis > 1mm
    BE CAREFULL YOU CAN CRASH THE BED INTO THE HEAD
    drop the head down to 0
    go back and use move z-axis 0.1mm (Use 0.025mm if needed)
    dial down slowly so that your paper is trapped (as if you were levelling manually)

    1. Go to Prepare > Auto home (this should result in X=70, Y=107, Z=10)
      After Auto home
    2. Go to Control > bed levelling> Probe Z Offset > [use the dial to select the desired offset]
    3. Go back and select 'Store settings' (scroll down to find it)
    4. and once more Go back and select 'Store settings' (scroll down to find it)
    5. Got to Control > bed levelling> Bed level
    6. This will then cause a final Z position of a higher number than before (Mine was Z12.87 for some reason)
    7. Run a bed level calibration print. If you need to make slight adjustments to the Z-Offset go through points 4 onwards using 0.025mm Z-axis movements.
    8. After your print make sure that you turn off the printer with the SD card still in the machine.

    I am still running some tests but all looks good so far.



  • I've switch to TH3D firmware for my ender 5 pro, WOW!!! i must say, everything is solved, now i have control over the printer, and can save the settings to the EEPROM.



  • I am having the same problem. Is there a solution? I haven't seen a fix for this on YouTube or any where else and I know others are having the same problem. It also seems to be on Ender 5 pro printers.



  • I am totally dead in the water without the Z offset. I have tried everything and I just can't get the Z offset to show up on my screen. Any help would be appreciated.



  • @T4 Still no real answer from Creality I'm afraid just a set of instructions to do what I have already done.
    For the time being, I have given up and have gone back to this firmware (V1.0.1)
    https://www.dropbox.com/sh/yb1k6mqdx5qzh97/AACwA-mbqqlKtLVW8A1azJh2a?dl=0
    as otherwise, the printer would be going back.
    As yet I haven't found a firmware update from Creality that works without a BLTouch.



  • This post is deleted!


  • Hello

    I had the same issue with Auto Home results: X=70, Y=107, Z=10

    What I did is go to Motion > move Z axis value resulting from Autohome to 0.00 (do not try to adjust paper thickness here, this is only to tell the machine were the cero is)

    Then go to Bed Leveling > Prove Z Offset and adjust the thickness there (paper thin)

    Then Save Settings

    To test run Autohome again and yes you will get a large number on Z but if you go onto motion and move the Z axis to 0.00, it should result in the paper thickness you calibrated.

    I hope it helps!



  • I have the same problem. Give it a solution?



  • @davidzohar This still does not fix the Z offset missing from the menu. You can't really use the BLtouch without the Z offset.



  • @davidzohar Thanks for that and I will keep it in mind, unfortunately, I turned my E5 on last night to discover a black screen (blue light on the board but no LCD).

    I removed the BLTouch and reflashed the firmware to V1.1.1 (Can't find a newer non BLTouch firmware) and all working again, Looks like the "Pinboard A" that sends to the LCD is faulty. Have contact Creality.



  • @davidzohar Thanks .. This fixed my problem. Weird how on V1.1.5 it used to beep and store on the board now it doesn't beep and require to store on SD.



  • @powerlines2000
    I had a similar issue, not sure its the same but try this:
    Control > bed leveling > Probe Z Offset > [use the dial to select the desired offset]
    Go back and select 'Store settings' (scroll down to find it)
    and once more Go back and select 'Store settings' (scroll down to find it)
    Also, one thing that drove me nuts was that if you don't keep the SD card in the SD card slot your settings will be gone if you turn the printer off. So make sure that your SD card is in all the time, during settings and during print...
    Hope this helps.



  • I have the exact same problem and I also tried several firmwares. None of them have the option to adjust the z offset.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.