Oh my, I have grown to hate my Ender 3 Pro's blank screen!

  • I just got a Ender 3 Pro (v1.1.4 I think) and a BlTouch (not v3) with it. No trouble with assembly, everything was fine, no trouble with install BlTouch. The final firmware update however, has given me a $200+ paperweight for the past 3 weeks. I finally was able to fix the driver issue with my pc, and went to flash the printer, which worked, I downloaded the new firmware (from Creality) and then followed the youtube video to install the new components, which I did per the video instructions. However now, after I installed the firmware update, using the progisp.exe, per the video instructions, I have a blank, black, screen, that refuses to do anything. Yes, there is power to the board, with the blue light active. I have tried backing up and reinstalling the firmware (with the settings from the video), I tried using the aspisp device (which I ended up having to get a new one that my US pc recognized), which didn't work, then I tried to install the firmware on a sdcard, which didn't work, then I tried backing up and uninstalling all the new parts, and checking lose connections, which also didn't work. I am at a lose and so far have grown to hate my new printer and the thought of 3d printing entirely, and I have yet to actually get to use it. What do I do? I don't even know where to start anymore, other than kindling, Suggestions?

  • Well, I have to admit, 1.4.1 is not working correctly. Guess, I do not have the correct 'extensions'. However, all the bins from the zip are booting. Give it a try. One will fit your needs ๐Ÿ™‚

  • Hi everybody ๐Ÿ™‚
    Agree, this post is it little bit old, however I had the same issue and was able to get the Ender 3 Pro running again ๐Ÿ™‚
    So let's hope my five cents are still useful to somebody...

    ( BTW, I accidentaly inserted a Raspberry Pi bootable SD, from which an obviously wrong ROM was loaded, when switching on the 3Pro... ;-/ )

    Some other posts mentioned "Original firmware" which I copied to a blank FAT formatted small sd card - and magic the blue screen went away and the Printer was booting up correctly.

    Sure, I did not want to use this old version, so I tried around with all the images.. so many tries, nothing worked..

    Although straight forward, I stupidly was not able to understand the file names present on Download Page: The numbers refer to the mainboard version!

    Did not find any sticker, pointing to the MB version, so, I needed to loose some screws and take a watch on the board:


    Take care when removing the cover, the fan is attached to it, so do not rip the cables!
    And here we find:


    So now it is clear, which file to pick from the Download Page page:
    In my case Ender-3 pro 4.2.2 mainboard firmware๏ผˆ32 bit๏ผ‰.zip

    I just took the newest version: Ender-3 Pro - Marlin2.0.1 - V1.4.1 - BLTouch - Filament.bin
    copied to the empty(!) FAT formatted SD, inserted into 3Pro and switched on..
    After ~30 seconds, the blue screen vanished and the 3Pro started to boot the new image. Printer-Info displays:


    Hope this is helpful.. ๐Ÿ™‚
    But now I have to leave and do some printing ๐Ÿ™‚


  • @shadovvs any resolution?