BLTouch and Cura



  • @Draude
    Thnks for the answer but that's not the issue. I want these lines because then you can be sure the extruder has put enough filament in the head to start the print flawless.
    The G-code G1 specifies to draw a first line to the back of the bed. Then move a little aside (here is the 'bug'). Then draw a second line back to the front.
    What happens: after the first line (X01 Y200.0), the head moves completely to the center of the bed extruding more filament. So my question was and still is: Where is here the G-code to do so??
    Then it returns to (X04 Y200.0) and draw the secondline (X04 Y20).



  • @gopanvn321 said in BLTouch and Cura:

    M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height

    I'm a not familiar with G-code.
    I've tried it, but the head does the same as without the G29. Only one measurement in the center of the bed and then prints the two lines.
    What I want to see is: after the start it does the G29 steps, measuring 9 points on the bed, then draw the first line, move a little to the right without going to the center of the bed and draw the second line. What the cura start-code is suposed to do (with G29 in it).
    Thanks.



  • @RoBe add the following after G28 in the slicer

    M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height



  • @admin Hi, I thought G29 is necessary for an automated leveling of the bed. Without G29 only the center of the bed is measured and that's it. Without G29 the two lines are drawn next to each other without going to the center of the bed. So the G29 template must conflict with the
    -G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little-.
    Do I have to report it to support or is there an other solution?



  • @admin I do not have anything to do with this thread.



  • Hi Rore and Tim, I don't get your point? Could you explain it to me? Appreciate it.



  • Robe,

    Look at the meaning of the G-Code lines that Cura is including at the start G-Code.

    The lines starting with G1... commands are doing exactly what you think is a firmware error, drawing two lines at the beginning of the 3D print.

    If you don't want any extra initial line on your 3D print, simply comment all G1 starting lines and they are not going to be printed in your nice 3D prints anymore.

    Hope it helps,
    Bye
    Draude



  • @admin Any suggestions on what to do next?



  • @admin
    Hi,

    I've tested it and without the G29 code, the Cura start G-code now prints the two lines without going to the center of the bed.

    Further solution(s) because eliminating G29 is not why I bought the BLTouch for?
    Thx.



  • @admin
    Hi,
    I will make a comment of the G29 code and try it later on. I'm currently printing a large object, so it will a while before I can test it.
    Thx.



  • @RoBe Hi, Please delete the G29 code, if there is still a problem, please refresh the firmware
    Ender-3 Pro1.1.6BLTouchV3.1PowerLossContinueEnglish.hex


Log in to reply