BLTouch and Cura

  • Hi,
    I installed 1.1.6BLTouchV3.1 PowerLossContinueEnglish 4.23 on Ender 3Pro.
    Before the update, sliced with Cura, the printer printed two lines.
    Starts from the front-left side to the back-left side, moves a little to the right en prints the second line back to the front.
    After the update, after bed levelling, the head moves to the starting point, front-left, prints the first line. Arrives at the back en goes quickly to the center of the bed, returns to the back and starts the second line towards the front.
    This is the start G-Code in Cura
    G28 ; Home all axes
    G29 ; Auto bed leveling
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder.

    I did not change anything except adding the G29 command.

    Is this a firmware bug or something else?

  • @SlackHacky
    Thanks for taking the time to explain about the M420 code.

    I too was expecting it to auto bed level the printer , never really read the comment with it.

    I've been doing an ABL whenever I switch the printer on. Using a card adapter on the E3V2 thats everytime I re-insert the memory card. Knowing this I can now just ABL if swapping memory cards or switching on the first time that day.

  • @admin I'm still waiting for any reply... after 6 days. Perhaps they could let one know that they are looking into it so one can be sure something is done?

  • @admin update from cs. It is indeed a bug. They gave me a new hex file to flash. But after flashing the firmware the display stayed black. I checked the connection on the mainboard, reflashed the firmware but the same result. So I reversed back to the hex file I was using before and the display is back on again. I replied this to cs and now I 'm waiting for their answer.

  • @SlackHacky I checked, but the last line available is: initialize EEPROM.

  • @RoBe info in 3rd square (control) on main screen then scroll down menu and its right at end and click it for info screen.

  • @RoBe ok, Robe, is you have anything I can help please feel free to let me know.

  • @SlackHacky forgot to answer the firmware.
    It was the stock firmware 1.1.6 for the BLTouch V3.1 from Creality. (After the flashing, one can not find the screen on the display anymore that gives you the version.)

    It's a line that's printed to the middle of the bed because the extruder stops extruding, but doesn't retract the filament in the head. It does the same thing on small file names.

  • @SlackHacky Thx for the explanation.
    I've found the meaning of the M420 code on internet and realised that it, as you explained, recalls the stored ABL mesh.
    I clean the bed everytime after the cooldown (i.e. glue) and before a new print(dust).
    I switch bed between PEI and glass depending on PETG or PLA and ABS filament.

    Is it necessary to use the Z in the M420 code?
    Thx again.

  • @admin OK. They've send me a mail asking for a video of the movement. Which I added in a reply.

  • @RoBe I have just sent your information to our after-sales support, If I have any information will feedback.

  • @RoBe Hi RoBe, Please send me the email screenshot, I will push them. Thank you.

  • @RoBe Right I shall explain a little better
    the G29 does a ABL ever time if you put it in G Code this is NOT needed (unless you want it)

    What you could do is 1st thing when you turn printer on daily and check it over and give it a quick clean - you do this right? 🙂 - is to run the auto bed level from menu and then save it by store configuration in menu - you have now saved your ABL Mesh, only do this when you do something that could upset it i.e remove glass, wack bed etc...

    now all you need after G28 INSTEAD of G29 is

    M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height

    this will recall from eprom or sdcard depending on firmware your saved ABL Mesh and use that to level your bed for prints.

    now as for the extruding lots of stuff in middle of bed, what firmware are you on? also keep file name under 22 characters i.e print.gcode NOT ender3_pro_i_will_use_too+long_ afile_name_today.gcode.

  • @admin I've send the mail to 8 days ago but until now, no respons at all.
    Is it possible to give them a wakeup call? Thx.

  • @admin
    Ok, I will do this.

  • @RoBe Dear Rore, for this question, I will suggest you contact our after-sales team.
    Hope they can help you to solve the issue.

  • @Draude
    Thnks for the answer but that's not the issue. I want these lines because then you can be sure the extruder has put enough filament in the head to start the print flawless.
    The G-code G1 specifies to draw a first line to the back of the bed. Then move a little aside (here is the 'bug'). Then draw a second line back to the front.
    What happens: after the first line (X01 Y200.0), the head moves completely to the center of the bed extruding more filament. So my question was and still is: Where is here the G-code to do so??
    Then it returns to (X04 Y200.0) and draw the secondline (X04 Y20).

  • @gopanvn321 said in BLTouch and Cura:

    M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height

    I'm a not familiar with G-code.
    I've tried it, but the head does the same as without the G29. Only one measurement in the center of the bed and then prints the two lines.
    What I want to see is: after the start it does the G29 steps, measuring 9 points on the bed, then draw the first line, move a little to the right without going to the center of the bed and draw the second line. What the cura start-code is suposed to do (with G29 in it).

  • @RoBe add the following after G28 in the slicer

    M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height

  • @admin Hi, I thought G29 is necessary for an automated leveling of the bed. Without G29 only the center of the bed is measured and that's it. Without G29 the two lines are drawn next to each other without going to the center of the bed. So the G29 template must conflict with the
    -G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little-.
    Do I have to report it to support or is there an other solution?

Log in to reply