Ender 3 Pro 4.2.7 BLTouch

  • Hello,

    I downloaded the firmware labeled "4.2.7V-Ender-3 Pro-32bit Mainboard-Marlin2.0.1- V1.3.1- BLTouch-TMC2225.bin" and had no problems. My 4.2.7 board was an upgrade for my Ender 3 Pro that came with a 4.2.2 board. With the 4.2.7 firmware, as mentioned above, I connected my BLTouch via the Pin 27 adapter board. Now, I would like to be able to change my Nozzle To Probe Offset after changing the BLTouch mount that I am using. Given that the source for the "4.2.7V-Ender-3 Pro-32bit Mainboard-Marlin2.0.1- V1.3.1- BLTouch-TMC2225.bin" has not been posted, what changes would I need to make when building Marlin in order to be able to use the Pin 27 Board like Creality has been able to achieve with their firmware? I have tried changing the Servo0_Pin to 27 from the default PB0 (also tried the default PB0), but this did not work- The firmware boots up just fine and the BL touch deploys out and back in during power up, but when trying to manually "deploy" the BLTouch from the menu, nothing happens. In addition, when Auto Homing, the BLTouch never deploys. Any help would be appreciated.

  • Dear @Zoompotato

    Is your motherboard 4.2.7 or 4.2.2, please refresh the bl touch of the corresponding motherboard,
    bl touch firmware download link: https://www.creality.com/download
    Please refer to this video to install bl touch:

  • If I remember correctly the following two lines need to be as follows:
    //#define USE_PROBE_FOR_Z_HOMING.

    Both are located at around line 855 in configuration.h

    you will also find:
    at around line 997

    If you print off and use this mount:
    your setting would need to be
    #define NOZZLE_TO_PROBE_OFFSET { -42, -10, 0 }

  • I have the same problem so any help would be greatly appreciated.

    I'm going to be honest, I'm a little shocked that you guys don't make the config files available.

Log in to reply