BL Touch and Silent board 4.7.2 not working together



  • Hi, I installed a 4.7.2 board on my ender 3 V1 and out of the box it worked fine, pretty silent indeed.

    Then I wanted to upgrade my firmware to allow my Creality BL Touch to work also, so I downloaded V4.2.7-Ender-3-32bit Mainboard_Marlin2.0.1- V1.3.1- BLTouch - TMC2225.bin from your website.

    This seemed to work fine, after flashing the unit started up but also the buzzer started beeping continuously so no longer that silent...

    On start up all seems ok, the BLT is extracting a few times and on the menu the BLT settings are visible, but not much additional happens.

    I tried with both the new on board connector (swapping the cables so they are correct) and the old 8bit add-on board as shown in one of your videos. But with the 8bit add on I got no screen at all, so I'm wondering what you really do in the video compared to what I do.

    Anyway, can someone tell me how I can get rid of the constant buzzer, or tell me where I can find the original firmware so I can put it back to factory settings? At least this way I can still enjoy the silent steppers and just return the BLT.

    It's either that or reinstalling the old 8bit board and return everything back because this is not the quality I expected.



  • Ok I found a solution that worked for me and I'm going to share it for the benefit of others.

    On the creality3dofficial.com website I found a link on the page of the silent main board v4.2.7 upgrade kit that took me to a well buried page with binary firmwares for Ender 3 and Ender 5 printers (https://www.creality3dofficial.com/pages/ender-series).
    They're not the most recent versions available on their main web site but, using the one from there (Ender-5_32bit_4.2.2_BLTouch_Marlin2.0.1 - V1.1.1), everything seems to be working as expected for me: no beeping and the BLTouch seems to be doing its job.
    There are also verions fo the board V4.2.7 and for the 8bit boards for both the Ender 3 and Ender 5 printers.

    Now I wonder: is it so difficult for the guys at Creality to keep a single repository of binary firmwares on their main website that keeps ALL the versions (both old and new) ever released for their printers so that we can roll back to an older version if the new one has issues?

    All the best to you all.



  • Hi.
    I am having the same issues with the same symptoms here.

    On top of that the BLTouch does not extend when homing nor when selecting "Deploy" in the "BLTouch" menu.

    I have a BLTouch V3.1 on an Ender 5 Pro with a 32bit board V4.2.2.

    The problem appeared when I installed the official Creality firmware "V4.2.2-Ender-5 Pro-32bit Mainboard-Marlin2.0.1-V1.3.1-BLTouch.bin" following the installation of the BLTouch probe.

    Does anybody know how to fix it?
    All the best.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.