Auto levelling installation problem (Ender 3 Pro, 4.2.2 motherboard, Two Trees 3D Touch)



  • I bought a Creality Ender 3 Pro printer in September 2020 and still enjoying printing some stuff for home.

    Several days ago I decided to upgrade my printer with auto-levelling sensor and bought one from Two Trees here https://aliexpress.ru/item/4001297485584.html?spm=a2g0s.9042311.0.0.274233edLk5S90 . It has the same wiring as an original BL Touch.
    Green – GND
    Red – +5V
    Yellow (orange) – Signal
    Black – GND
    White – Z min

    When I opened a motherboard box I was surprised to find a 4.2.2 mainboard, which has a separate 5-pin white connector marked bl_t. As I understand it is for BL-Touch. I've made connections like this:
    Green – GND to G pin
    Red – +5V to V pin
    Yellow (orange) – Signal to IN pin
    Black – GND to G pin
    White – Z min to OUT pin

    Then I downloaded firmware V4.2.2-Ender-3 Pro-32bit Mainboard-Marlin2.0.1-V1.3.1- BLTouch.bin from this link https://www.creality.com/download .

    Here I encountered a problem, I can't deal with. When I connected my 3D Touch, flashed a printer with the new firmware it started to beep continuously with beeper under the display, all the until printer power is off. The 3D Touch lit blue and red. In some seconds after power on it pushes out and back a probe, then do nothing. Even if I reset it through menu nothing happens. Probe not moving when I select "Auto home", although the hot end moves to the center of the bed.
    Even if I disconnect 3D Touch physically and then power on the printer, beeping starts on power on and continues until power off.

    I tried to disconnect Z-axis endstop physically, it doesn't help.

    I also tried a Ender-3_Firmware 32bit4.2.2_Marlin2.0.1 (not supports BL Touch) from https://www.creality3dofficial.com/ru/pages/copy-of-ender-series with my 3D Touch connected and found out that 3D Touch randomly pushing probe out for about 2 seconds and in.

    Please help me make auto-levelling work.



  • Dear @Idler115

    From your purchase link, bl touch does not have an adapter board, please use this bl touch firmware:

    Ender-3 Pro- Marlin2.0.1 - V1.1.2 - BLTouch.bin



  • After posting this I went on searchig for tie information and discovered one more version on firmware for 4.2.2 mainboard and BL Touch here: https://www.creality3dofficial.com/ru/pages/copy-of-ender-series

    You need Ender-3_BLTouch 32bit_4.2.2_Marlin2.0.1 link.

    With this firmware everything works perfect.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.