CR10S-Pro-V2



  • So my printer arrived 10 days ago... opened setup worked for 90 seconds then froze at the Creality startup page. I've spent 2-4 hrs/night trying to fix this software issue. The following fixes have been attempted... to no avail. I formatted my SIM and downloaded the display driver for my machine. The flash seemed to work correctly as per YouTube video tutorials. Removed the SIM powered down and up with the display driver showing CR-10S Pro V2 startup screen with the white load bar static at the bottom fixed on white. I then downloaded Marlin for my machine and attempted to flash the firmware using both Cura and Creality Slicer with my printer selected. Both failed to even recognize the printer as connected. Then I tried loading Xloader and it says uploading... with no upload taking place. Then I tried using Arduino uploader as per YouTube tutorials again no luck.

    So I've paid close to a GRAND for what is currently a 30 hour time sink. I ordered a printer that doesn't work. I've tried contacting the supplier Comgrow no luck, no Western phone number no response from email. I tried contacting Creality directly again no response. I tried contacting Amazon, no response. I tried help groups such as those on Facebook with some help but again my problem is not solved. FRUSTRATING AS HELL...!

    Anyone PLEASE help me.. I haven't yet reviewed this product with AMAZON... Soon though!


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.