CR-6 SE NEW FIRMWARE UPDATE



  • For those who have Problems flashing the Screen Firmware:

    I also tried to flash with a 4k formatted 32GB MicroSD Card and it worked.
    Is used MiniTool Partition Wizard Free for formatting.

    Thank you!



  • Dear @yvesware

    Please take a picture of the motherboard when you disassemble the machine so that we can send you the corresponding firmware and tutorial



  • Help, I copied the bin file for the mainboard firmware and tried to update the firmware, Now my printer is stuck at the creality screen!! (Seriously !!!)..................... I tried to power on/off and now well printer is "bricked"

    All help appreciated.

    NOTE:Also there is the display firmware, what's the process for that ?



  • @Bogill said in CR-6 SE NEW FIRMWARE UPDATE:

    I think that the steppers sounds much louder after the update. Anyone?

    Too hard to tell over the noise of the fans 😛 ! Seriously I noticed that as well but not until you brought it up.



  • @spauliszyn Strictly talking you won't ever get EEPROM active on this machine because the Microcontroller has none of it 🤣 BUT the trick Marlin uses to overcome it is to reserve a piece (2K if I recall correctly) at the end of the program flash OR use the SD as replacement 😉

    Now as an engineer, you have to choose because as flash devices both the SD and the internal flash will become old with the erase/program cycles and then malfunction. They choosed wisely because a SD is easily an cheaply replaced but we (I do too) prefer to use the micro internal flash. This will shorten the life of our motherboards in exchange of having a self sufficient device, it is ok to me, I assume than also to you, but I can't talk for all the people, I understand that Creality engineers are taking their time to decide.

    Sorry if this sounds weird, my native language is not english.



  • Except... EEPROM is supposed to be a chip on the motherboard with non-volatile memory storage. Although there may be an EEPROM on the motherboard, the firmware is currently using the SD card to store the information.

    At least for now, this will allow the printer settings to be saved and retrieved. For me, I connect the printer to a computer so that I don't need to pull the SD card in order to update g-code files. But for those who do use the SD card for g-code files it is a bit inconvenient because they could delete the file. And it is very inconvenient when you use more than one SD card and the settings could be different on each card.

    But this is not a proper fix for storing printer settings and is very inconvenient for those using SD card for g-code. @admin you need to get the EEPROM working on the motherboard. This is not new technology so why the delay?



  • @Daverobbo1904 m500 can work today on this firmware. If you put in an SD Card, it'll save EEPROM data to a file on the SD



  • @pro_info Insert an SD Card and it'll save save the EEPROM data there in a file.



  • I've uploaded to the latest firmware and it seems to be working fine. (But It would be nice to have a change log. )
    For people having print quality issues, I highly recommend this website as it did wonders for the print quality on mine.
    https://teachingtechyt.github.io/calibration.html
    With regards to the printer scratching the surface when you cancel a print.
    I'm quite new to Arduino and programming, but on the Marlin website I find. This gcode.
    G28. Auto home.
    I should think that is what is activated when you cancel the print? And if the X is added then it will work as the other printers and raise the head a bit before returning.
    Hopefully this will be added in the next update.

    [Y] [Z]

    Parameters
    [O]
    Optional. If the position is known then exit without homing. (1.1.9)
    [R]
    Raise before homing distance (1.1.9)

    Flag to go back to the X axis origin
    [Y]
    Flag to go back to the Y axis origin
    [Z]
    Flag to go back to the Z axis origin



  • So we have firmware that’s been provided with almost everyone saying something is wrong and yet we haven’t had it patched.



  • @agentd5417 I haven't run a real print with this firmware yet, just installed it. In the past I've always had to recalibrate after firmware updates, to account for differences in the firmware. GCODE that worked fine on old firmware may be no good on this firmware, I'd try recalibrating and re-slicing those STLs to see if that resolves the problem.



  • The trick is, for sure, formatting the SD Card with MS-DOS 4k block size (named cluster size in windows). I used a SanD*** 64GB Micro SD XC Card and formatted it under my Fedora 32 Linux with the following tasks:

    first find device name

    [markus@james markus]$ lsblk 
    NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
    sda                                             8:0    0 931,5G  0 disk  
    ├─sda1                                          8:1    0     1G  0 part  /boot
    └─sda2                                          8:2    0 930,5G  0 part  
      └─luks-af9208ea-4b75-4f65-956d-e1e34ba77648 253:0    0 930,5G  0 crypt 
        ├─fedora_james-root                       253:1    0    50G  0 lvm   /
        ├─fedora_james-swap                       253:2    0   7,9G  0 lvm   [SWAP]
        └─fedora_james-home                       253:3    0 872,7G  0 lvm   /home
    mmcblk0                                       179:0    0  59,5G  0 disk  
    └─mmcblk0p1                                   179:1    0  59,5G  0 part  /run/media/markus/F085-FF0F
    

    Then check actual cluster size

    [markus@james markus]$ sudo dosfsck -v -n /dev/mmcblk0p1
    [sudo] password for markus: 
    fsck.fat 4.1 (2017-01-24)
    Checking we can access the last sector of the filesystem
    0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
     Automatically removing dirty bit.
    Boot sector contents:
    System ID "mkfs.fat"
    Media byte 0xf8 (hard disk)
           512 bytes per logical sector
         32768 bytes per cluster    <<<===== 32k
            64 reserved sectors
    

    Then re-format the sd-card

    [markus@james markus]$ sudo mkdosfs -s 8 /dev/mmcblk0p1    <<<===== -s Value is double the block size 
    mkfs.fat 4.1 (2017-01-24)
    [markus@james markus]$ 
    

    At least check again the result

    [markus@james markus]$ sudo dosfsck -v -n /dev/mmcblk0p1
    fsck.fat 4.1 (2017-01-24)
    Checking we can access the last sector of the filesystem
    Boot sector contents:
    System ID "mkfs.fat"
    Media byte 0xf8 (hard disk)
           512 bytes per logical sector
          4096 bytes per cluster    <<<<===== now 4k
            32 reserved sectors
    

    After this flashing the display works - see picture
    d97fa9b5-a4c2-47ed-a3de-377ea81fd579-image.png



  • Hello!

    I tried to update the screen firmware and nothing seemed to happen.

    I formatted a microsd card in fat32, 4k clusters and put the DWN_SET (from the CR-6 SE -source code V1.0.3.6 package) folder at the root.

    With that in the screen sd slot, my CR-6 se boots normally to the main screen without any delay.

    From what I've seen in some videos, the screen should go through some color changes during the update and I should have to remove the card and reboot to get to the main screen.

    That didn't happen with my unit. Just to be sure, I tried the update with 2 different SD cards.

    • On the CR-6, is there supposed to be any visual indication of the screen firmware update happening?

    • Is there a way to verify if the update worked?

    Otherwise, that might indicate that the SD card reader on my CR-6's screen isn't working...

    Thanks!



  • I think that the steppers sounds much louder after the update. Anyone?



  • Installed the firmware update yesterday evening, and ever since a successful installation my prints keep coming up with massive gaps and stringing. I'm new to this, but every gcode i put in new and prior saved, fail to extrude evenly and creates these messy rats nests.



  • @Stonedog03 did the same thing. Took a while to figure out how to do it on a mac but i was finally able to. And it worked! Thank you!



  • @alan3664 @Haste9r Thanks! That did the trick! Had to dig around a bit to find an SD card small enough to accept 4k clusters!



  • @Stonedog03 Use 4K clusters as Haste9r suggests. FAT32 default cluster size varies with the size of the SD. I use a 32GB SD formatted with 4K Clusters and the printer is able to read it.



  • @Stonedog03 Check to see if your sd card is formatted to 4k clusters that fixed it for me.



  • @Stonedog03 I am also having the same issue.


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.