CR-6 SE NEW FIRMWARE UPDATE



  • The trick is, for sure, formatting the SD Card with MS-DOS 4k block size (named cluster size in windows). I used a SanD*** 64GB Micro SD XC Card and formatted it under my Fedora 32 Linux with the following tasks:

    first find device name

    [markus@james markus]$ lsblk 
    NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
    sda                                             8:0    0 931,5G  0 disk  
    ├─sda1                                          8:1    0     1G  0 part  /boot
    └─sda2                                          8:2    0 930,5G  0 part  
      └─luks-af9208ea-4b75-4f65-956d-e1e34ba77648 253:0    0 930,5G  0 crypt 
        ├─fedora_james-root                       253:1    0    50G  0 lvm   /
        ├─fedora_james-swap                       253:2    0   7,9G  0 lvm   [SWAP]
        └─fedora_james-home                       253:3    0 872,7G  0 lvm   /home
    mmcblk0                                       179:0    0  59,5G  0 disk  
    └─mmcblk0p1                                   179:1    0  59,5G  0 part  /run/media/markus/F085-FF0F
    

    Then check actual cluster size

    [markus@james markus]$ sudo dosfsck -v -n /dev/mmcblk0p1
    [sudo] password for markus: 
    fsck.fat 4.1 (2017-01-24)
    Checking we can access the last sector of the filesystem
    0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
     Automatically removing dirty bit.
    Boot sector contents:
    System ID "mkfs.fat"
    Media byte 0xf8 (hard disk)
           512 bytes per logical sector
         32768 bytes per cluster    <<<===== 32k
            64 reserved sectors
    

    Then re-format the sd-card

    [markus@james markus]$ sudo mkdosfs -s 8 /dev/mmcblk0p1    <<<===== -s Value is double the block size 
    mkfs.fat 4.1 (2017-01-24)
    [markus@james markus]$ 
    

    At least check again the result

    [markus@james markus]$ sudo dosfsck -v -n /dev/mmcblk0p1
    fsck.fat 4.1 (2017-01-24)
    Checking we can access the last sector of the filesystem
    Boot sector contents:
    System ID "mkfs.fat"
    Media byte 0xf8 (hard disk)
           512 bytes per logical sector
          4096 bytes per cluster    <<<<===== now 4k
            32 reserved sectors
    

    After this flashing the display works - see picture
    d97fa9b5-a4c2-47ed-a3de-377ea81fd579-image.png



  • Hello!

    I tried to update the screen firmware and nothing seemed to happen.

    I formatted a microsd card in fat32, 4k clusters and put the DWN_SET (from the CR-6 SE -source code V1.0.3.6 package) folder at the root.

    With that in the screen sd slot, my CR-6 se boots normally to the main screen without any delay.

    From what I've seen in some videos, the screen should go through some color changes during the update and I should have to remove the card and reboot to get to the main screen.

    That didn't happen with my unit. Just to be sure, I tried the update with 2 different SD cards.

    • On the CR-6, is there supposed to be any visual indication of the screen firmware update happening?

    • Is there a way to verify if the update worked?

    Otherwise, that might indicate that the SD card reader on my CR-6's screen isn't working...

    Thanks!



  • I think that the steppers sounds much louder after the update. Anyone?



  • Installed the firmware update yesterday evening, and ever since a successful installation my prints keep coming up with massive gaps and stringing. I'm new to this, but every gcode i put in new and prior saved, fail to extrude evenly and creates these messy rats nests.



  • @Stonedog03 did the same thing. Took a while to figure out how to do it on a mac but i was finally able to. And it worked! Thank you!



  • @alan3664 @Haste9r Thanks! That did the trick! Had to dig around a bit to find an SD card small enough to accept 4k clusters!



  • @Stonedog03 Use 4K clusters as Haste9r suggests. FAT32 default cluster size varies with the size of the SD. I use a 32GB SD formatted with 4K Clusters and the printer is able to read it.



  • @Stonedog03 Check to see if your sd card is formatted to 4k clusters that fixed it for me.



  • @Stonedog03 I am also having the same issue.



  • @alan3664 Using the DWIN_SET from the source code RAR did not work for me either. Same result as what @bstefans16 was getting. I tried the DWIN_SET from "CR-6 SE -source code V1.0.3.6.rar" and also the one inside of "DWIN_SET.zip.saving" from the "CR-6 SE 32BIT latest firmware--V1.0.3.6.rar" set. They all result in the same message as seen by @bstefans16 .

    Any suggestions?



  • Ok so I just read this thread and I am thoroughly confused.

    There are three files on the web site, two of which have the same date and name. They have two subdirectories (screen/mainboard).

    I assume to update I copy something to the SD and cycle the power.

    Question is: which files should I copy to the SD? Do they really work or not?



  • @bstefans16
    Hi,
    Use the DWIN_SET files from CR-6 SE -source code V1.0.3.6.rar - they are OK..
    The files included in CR-6 SE 32BIT latest firmware--V1.0.3.6.rar are bad: The files in the folder DWIN_SET are the ones from the CR-6 SE_32-bit_V1.0.2.bin_200907.rar and missing the T5L_UI_DGUS2_V14.BIN .There is a DWIN_SET.zip.saving which is the ZIP with the new files but the encoding of the Chinese filename is wrong.



  • I updated the board firmware no problem but the screen firmware is acting odd. I’m getting the blue screen after about 2-3 sec, but it immediately says SD Card Process . . . END ! And lists the different type of files below with all of them having a number of 000 on the right.

    I assume it would list the number of each of those types of files included in the screen firmware, no? I tried to redownload the file, reformat the micro sd, nothing.

    Some info - i have a micro sdhc (not sdxc). Is that compatible? What else could be the reason?

    I’ve included an image below:
    F95CE824-F8F4-43CD-B040-675675C62BFD.jpeg



  • On Youtube there are two different updates shown. One on the front of the printer and one when you open it and insert a microsd into the board underneath the touchscreen.
    Can you tell which files go into which section?
    thanks



  • it would be nice if the firmware can read more than 5 pages of files, it's kind of annoying to look for old files when it can only read files up to 5 pages



  • I'm running V1.0.3.6 still having two annoying issues:

    1. The nosle scratches on the print bed if i cancel the print while printing the first layer
    2. The bed leveling data get lost on a power cycle, so I need to repeat the bed leveling before every print


  • @pro_info That's a bummer, that's the biggest issue I had with the firmware, that and M600 not working.



  • @ncbob No

    /**
     * EEPROM
     *
     * Persistent storage to preserve configurable settings across reboots.
     *
     *   M500 - Store settings to EEPROM.
     *   M501 - Read settings from EEPROM. (i.e., Throw away unsaved changes)
     *   M502 - Revert settings to "factory" defaults. (Follow with M500 to init the EEPROM.)
     */
    #define EEPROM_SETTINGS     // Persistent storage with M500 and M501
    //#define DISABLE_M503        // Saves ~2700 bytes of PROGMEM. Disable for release!
    // #define EEPROM_CHITCHAT       // Give feedback on EEPROM commands. Disable to save PROGMEM.
    #if ENABLED(EEPROM_SETTINGS)
      //#define EEPROM_AUTO_INIT  // Init EEPROM automatically on any errors.
    #endif
    

    Yes, but when I do an M500, it doesn't work for me.



  • The archive contains of two folders: "32bit mainboard firmware" and "32bit screen firmware". Should I copy files from each folder and run them separatly from SD card or should I place all files all together and run them at the same time? Would be nice to have specific instruction. Thank you in advance for respond.



  • Is the EEPROM enabled in this version?


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.