CR-6 SE NEW FIRMWARE UPDATE



  • @alan3664 @Haste9r Thanks! That did the trick! Had to dig around a bit to find an SD card small enough to accept 4k clusters!



  • @Stonedog03 Use 4K clusters as Haste9r suggests. FAT32 default cluster size varies with the size of the SD. I use a 32GB SD formatted with 4K Clusters and the printer is able to read it.



  • @Stonedog03 Check to see if your sd card is formatted to 4k clusters that fixed it for me.



  • @Stonedog03 I am also having the same issue.



  • @alan3664 Using the DWIN_SET from the source code RAR did not work for me either. Same result as what @bstefans16 was getting. I tried the DWIN_SET from "CR-6 SE -source code V1.0.3.6.rar" and also the one inside of "DWIN_SET.zip.saving" from the "CR-6 SE 32BIT latest firmware--V1.0.3.6.rar" set. They all result in the same message as seen by @bstefans16 .

    Any suggestions?



  • Ok so I just read this thread and I am thoroughly confused.

    There are three files on the web site, two of which have the same date and name. They have two subdirectories (screen/mainboard).

    I assume to update I copy something to the SD and cycle the power.

    Question is: which files should I copy to the SD? Do they really work or not?



  • @bstefans16
    Hi,
    Use the DWIN_SET files from CR-6 SE -source code V1.0.3.6.rar - they are OK..
    The files included in CR-6 SE 32BIT latest firmware--V1.0.3.6.rar are bad: The files in the folder DWIN_SET are the ones from the CR-6 SE_32-bit_V1.0.2.bin_200907.rar and missing the T5L_UI_DGUS2_V14.BIN .There is a DWIN_SET.zip.saving which is the ZIP with the new files but the encoding of the Chinese filename is wrong.



  • I updated the board firmware no problem but the screen firmware is acting odd. I’m getting the blue screen after about 2-3 sec, but it immediately says SD Card Process . . . END ! And lists the different type of files below with all of them having a number of 000 on the right.

    I assume it would list the number of each of those types of files included in the screen firmware, no? I tried to redownload the file, reformat the micro sd, nothing.

    Some info - i have a micro sdhc (not sdxc). Is that compatible? What else could be the reason?

    I’ve included an image below:
    F95CE824-F8F4-43CD-B040-675675C62BFD.jpeg



  • On Youtube there are two different updates shown. One on the front of the printer and one when you open it and insert a microsd into the board underneath the touchscreen.
    Can you tell which files go into which section?
    thanks



  • it would be nice if the firmware can read more than 5 pages of files, it's kind of annoying to look for old files when it can only read files up to 5 pages



  • I'm running V1.0.3.6 still having two annoying issues:

    1. The nosle scratches on the print bed if i cancel the print while printing the first layer
    2. The bed leveling data get lost on a power cycle, so I need to repeat the bed leveling before every print


  • @pro_info That's a bummer, that's the biggest issue I had with the firmware, that and M600 not working.



  • @ncbob No

    /**
     * EEPROM
     *
     * Persistent storage to preserve configurable settings across reboots.
     *
     *   M500 - Store settings to EEPROM.
     *   M501 - Read settings from EEPROM. (i.e., Throw away unsaved changes)
     *   M502 - Revert settings to "factory" defaults. (Follow with M500 to init the EEPROM.)
     */
    #define EEPROM_SETTINGS     // Persistent storage with M500 and M501
    //#define DISABLE_M503        // Saves ~2700 bytes of PROGMEM. Disable for release!
    // #define EEPROM_CHITCHAT       // Give feedback on EEPROM commands. Disable to save PROGMEM.
    #if ENABLED(EEPROM_SETTINGS)
      //#define EEPROM_AUTO_INIT  // Init EEPROM automatically on any errors.
    #endif
    

    Yes, but when I do an M500, it doesn't work for me.



  • The archive contains of two folders: "32bit mainboard firmware" and "32bit screen firmware". Should I copy files from each folder and run them separatly from SD card or should I place all files all together and run them at the same time? Would be nice to have specific instruction. Thank you in advance for respond.



  • Is the EEPROM enabled in this version?



  • @admin any idea when that will be please
    thank you



  • Dear @Daverobbo1904

    As I know, this firmware is confirmed before your question, then I don't think it has been added in. But I have sent your suggestion to our engineer and will confirm if it will be added to the next firmware.



  • @admin thank you for that can you confirm that the M600 command has been added


Log in to reply
 

Copyright © 2020 Shenzhen Creality 3D Technology Co., Ltd All Rights Reserved.