I think the motor speed has been set to slow. Try changing it to 3mm/sec on parameter settings and try levelling again. Thats how my levelling movement became faster