After updating the firmware on my Creality CR10S, my screen starts up but doesn't display anything

After updating the firmware on my Creality CR10S, my screen starts up but doesn’t display anything.
The update was from Marlin 2.1 to Marlin
I tried to go back to Marlin 2.1 and the problem is the same.
I’ve tried with versions 2.0.97 and, but this version won’t compile - library error.
Do you have any suggestions for research or corrections?
Thanks a lot

I’ve managed to go back to Marlin version 1.1.9. I’ve got my display back.
My other problem is that I can’t get past 195° and an alarm goes off telling me to turn off the printer. This alarm is a head heating timeout.
My setpoint is 202°. At 195°, the temperature stagnates, then timeout with alarm.

Hey. Sorry to hear you’re having issues. The heating issue may be a faulty thermistor and that’s always the best place to start troubleshooting. I’d suggest replacing it and see if that solves it.

Going back to the firmware issue, in some cases you have to also update the screen firmware so it might be worth taking a look at that.

Thanks for the advice.
Can you tell me more about the Thermistor, is it the resistor that heats the head? Normally it’s almost new. But I’m going to change it again to check.

I don’t know what to do about the screen firmware. Do you know of a tutorial I can follow?
Thank you very much.

No worries. The thermistor is the white wire attached to the side of the hotend. They’re very temperamental so can easily become faulty.

With the screen firmware, I’d say it was just a theory of mine but could well be the issue. Have a search online for tutorials as there’s always a YouTube video for these sort of things. I did write a tutorial for general flashing of firmware which is on the Creality Cloud so I’ll send you a link to that which might help.

Here are my two articles on firmware. This might seem basic but there might be something in there which helps

1 Like

Thanks, I’m looking into it.

1 Like

Thanks a lot!

1 Like