AI - anything but intelligent. :-(

Is it just me or is the AI completly useless on the K1 Max? It doesn’t detect spaghetti messes. It doesn’t detect not printing anything at all. It doesn’t detect when the ZIG-ZAG pattern it draws every now and then is a mess.

The only thing it does detectso far, is when I forgot to put the print plate back in.

I’ve tried setting the mode to Professional and Conventional… doesn’t seem to do anything any different.

I don’t know much how it works or doesn’t work… :cry:

Are you using Creality Print…?

Mine actually detected spaghetti messes a couple firmware updates ago…
I don’t know what changed…

I’ve only used the most recent two firmwares. So that’s all I’ve experienced. New to 3D printing, the things I’m most interested in it recognizing and halting… are spaghetti (when I without realizing have an object not touching the object below creating empty layers) and not printing anything (when I did the previous mistake, the filament broke, or there’s a clog). I’ve encountered these problem in particular with TPU, which has been very difficult to print with thus far - with about 90% failure rate. I’m hoping using a dryer while printing will resolve that.

I’ve actually turned all that off because like you said it doesn’t seem to do anything… Once in a while I’ll turn it on to watch the Lidar thingy do “stuff”

The only time I’ve seen the lidar come on… or so it appears (red rays)… is when it draws the zig zag pattern to the left side of the plate. I had turned it all off, but after having an 8 hour print go to spaghetti after I went to bed, and waste 1/4 roll of filament, I turned it back on hoping some how magically it’d start working. Since turnign on though I haven’t had any issues for it to catch. I’ve learnt a lot though so I’m less apt to screw up. Except with TPU… haven’t figured that filament out yet. But, I also haven’t delved into other filaments I’ve gotten like wood, ASA, and carbon fiber yet.

Wow. Sorry about wasted filament and time…

Kind of the same situation here. Mostly PLA but trying PETG which actually came out good once I bumped up the temps and figured out that adhesive on PETG is to keep the model from sticking too much… Made more sense after I ruined a plate… :cry:

I did try wood filament and got some big time clogs. Have to change the nozzle to a larger size.

Mine has been running good lately except for pilot errors…
My filament sensor went out the other day for some reason… Not a big deal that I can’t live with for now…

It’s all good… :+1:

I’ve been wondering about the filament sensor… I presume it’s the little box at the back. If so, are you supposed to do the retraction step to push it back out enough to be able to pull it out and replace with new spool (wasting a few feet in the process)… or do you have to pull it out at the extruder end? I wondered if you could perhaps start feeding a new roll in behind the first, just manually pushing it to avoid wasting the end of the first roll.

I’ve done it both ways.

I’ve done it that way and it does work. You can change colors that way too. It just takes a few minutes to finish… I usually only do that if I have a roll with only a small amount on it and I want to use it up…

To change rolls I just hit retract, let it do it’s thing, unlock the extruder and then pull the filament all the way out carefully. Feed a new one in, lock the extruder and hit extrude.

i just meant that at the point it would detect its out of filament, there’s still a foot or two of filament in the tube after the sensor to the extruder. I’ve not let it get this far though because I wasn’t sure if you retract at the point it stops, because the sensor says its out of filament, if it would push it back out the back enough to be able to pull it out I’m guessing not because there’s about a foot of tube before the sensor. Or if instead you have to pull that bit out by detaching the tube from the extruder… which seems like a lot of extra effort in the middle of a print… to add another roll. So, in my head I was thinking that pushing the 2nd roll in behind the 1st roll would be the way to do it to avoid wasting a couple feet of filament.

BTW I figured out that you don’t have to unlock the extruder to pull out the filament after a retract. Only to push in a new filament to extrude. I also figured out you don’t have to take the top cover off to unlock the extruder… you can reach in and up from the front. Saves a bit of hassle.

I see what you’re saying… Yup… makes sense…!

Good idea :+1: although when I’m using PLA I never put the top cover on. It makes it too hot in the chamber…Up to 35°C sometimes it the room is warm… Had the nozzle clog up because the PLA would get too warm and not be able to be pushed out…(found that out the hard way… :cry:)
At least that’s what I found reading online.

You should always unlock the filament clamp when removing filament otherwise you run the risk of molten filament getting jammed between the gears and the locking mechanism. Small strands can get wrapped in the gears and will cause jamming. I would strongly recommend that you always unlock the filament clamp before pulling out retracted filament.

1 Like

I’ve not had any clogging issue with PLA with the cover on. The cover itself indicates to only remove it for PLA if the room temperature is > 30C. I presume that the english is correct and room refers to the physical surrounding room… rather than inside the printer.

That’s true and I agree with you. I could probably leave it on but the one experience I had where the chamber temp got up to 36 with the cover on and the PLA got all soft is when it clogged so I just don’t take a chance any more… :cry:
Now that I think about it more it could have been because of the hot end was not the upgraded one…??? Not sure. I’ve since then put the upgraded hot end on.

To 3dee: Hope this helps answer your AI question. 1st, on your K1 Max control screen, choose “Settings”. Across that screen is three tabs. Choose the 3rd tab, “Camera”. In the Camera screen choose “AI”. ONce there, make sure "AI detection is turned on, then check the “Printing paused due to faults” is checked. You can then go to "Sensitivity - First layer detection, click on the “Conventional” arrow, and you can select Conventional or Professional, depending how often you want it to scan for defects. Then you can back out and go to the “Home” screen. This should do the pause that you’re looking for. I’ve found that, sometimes, it will pause for a fault that doesn’t exist. But if you’re wantiong it to pause at night to keep from wasting filament when your asleep, this should do the trick.

I’ve tried all of those settings. They do nothing for me. The only detection that caused a pause that I’ve seen thus far is it telling me there’s something on the plate. though in actuality, I get that error when I’ve forgotten to put the plate back in.

Notably, most of the spaghetti issues I’ve had, did not occur on the first layer.