ASA Filament - First layer failing to stay on bed

I purchased a roll of Flashforge ASA filament for use on a Creality K1 Max. I initially began with the Generic ASA profile in Creality Print 4.3.8 software. I’m having a terrible time with first layer printing however… failing to stick to the bed about 75% of the time.

I’ve tried releveling the bed, lowering the Z axis (-0.10), reducing the first layer print to 10 mm/s, altering/zeroing fan speed (< 10%), increasing bed temperature above 100 degrees. I’ve also tried using a filament dryer - but this never seems to accomplish anything with any filament. Nothing makes much difference.

On the topic of bed leveling, I currently have this extreme looking graph…


But sometimes when I do this leveling it comes up with something seemingly less extreme.

Though I need to print about 30 similar objects, I’ve had to resort to printing one at a time, because the failure rate at start is so high, I inevitably have to halt the print and scrap multiple objects. Sometimes I am able to use the Exclude Object feature after I see one is going to fail, but this more often says it’s excluded, but doesn’t X it out in the GUI, and doesn’t actually exclude it.

I’ve not had this problem with any other filament type. I really don’t know what else to try.