Autobed leveling issue

Hi everyone, hope everyone’s doing good, I’ve had this problem recently with the bed leveling and I can’t work out what’s happening, since the bed mesh is good but the first layer of prints shown in the photo have areas where it’s obviously too far from the bed shown in top right. And when it’s slightly too close shown in bottom left. Recently the extruded dug into the bed shown in the photo as well not sure if this is linked ?

Hi @Matthew_Byrnes and welcome to the forums.

You should be able to make adjustments to the z offset within the slicer, this may help with your first layers.

In regards to the damaged bed… yes this could be causing an issue as if the bed is bent/damaged it could result in a poor or incorrect mesh of the bed being generated.

If you can I would recommend investing in a new build plate to see if that rectifies the issue.

Hi @Nikoli, thanks for the reply, as there are some areas where the nozzle is too close and too far lowering the z offset will make the closer areas even worse? In terms on the levelling of the bed my bed mesh result is pretty good which I will attach below.

It really depends on how much you adjust the Z offset, usually most people will make adjustments at 0.05 increments to find the sweet spot. Your mesh looks pretty good!

A firmware update is due for the K1 series printers in the coming days and some of the fixes seem to relate to better first layers so you may find that once the update is released your first layers will be a lot cleaner.

Where are you reading that? Im interested and seeing what they have in the firmware update. Especially when I am having auto bed level compensation issues myself.

Okay thanks I’ll sit tight

1 Like Changelog

What’s New

  • LiDAR pressure advance re-worked(Only K1 Max), compatible with Creality Print, Prusa, Orca slicers. Support PLA/PETG/ABS… etc. typical non-soft filament types.
  • Expert mode - adjust flow rate and z offset on the fly. As well as hot end PID tune.
  • Speed control - Quite/Stable mode(50%), Standard mode(100%), Ultra fast mode(125%)
  • Support object exclusion
  • Support Korean language


  • Optimize filament runout algorithm
  • Chamber fan algorithm update, no longer turn on by default when the print start. Instead it will trigger and control by chamber temperature.
  • Add filament runout indication on main page.


  • Fixes object exclusion cause UI freezing and/or blank screen.
  • Fixes inconsistent display between Web UI and LCD display of maximum hot bed temperature.
  • Fixes time sync and app not displaying camera problem in some rare cases.
  • Fixes special characters filament name cause print task cannot be completed.

Several other improvements and tweaks have been made which are currently unlisted until official release of the firmware.

I know of at least 2 people currently testing the firmware and have commented on how much better their first layers were and overall print quality was better.

1 Like

Can’t wait to try this new one out… :+1: