Cannot Connect to Falcon

I am beyond frustrated! Laser works OK stand alone, but after trying to connect with a WIN 11 PC, a MAC, a new USB cable, AND A NEW MOTHER BOARD, I still cannot connect! I have tried connecting with LaserGBL AND with Lightburn. What am I doing wrong!!! ???

So which system are you trying now? With the PC, what shows in the device manager when you plug it in?

I have tried a Mac book pro running IOS 12.7 with no luck.
I have concentrated on troubleshooting with a Win 11 PC using a new USB DATA cable. I just had the PC totally updated (new drivers etc). I have loaded the config file for falcon into LB. when looking at devices on the PC, nothing is added when I plug into the Falcon controller. LB indicates it is trying to connect. I am an hour away from the laser now so I can’t answer your question.
So far no connectivity to a MAC or a PC running LB or LaseerGBL.

Oh I forgot ! when I complained to Creality they had me update the F/W: No change.
I got them to send me a new mother board: no change.