Can't flash firmware on Ender 3 v2 Neo - GD32F303 Chip, v4.2.2 Motherboard

I haven’t been able to flash my Ender 3 v2 Neo for a week now. Basically, I’d like to install klipper, but if I can just install the basic firmware, I’ll be happy…

With the 8 GB micro SD card supplied by Creality and formatted in FAT32 with 4096 bytes of cluster, I tried to flash these firmware: (Folder V4.2.2-GD MCU) and a klipper compilation following this guy’s parameters on github (

Every time, same result, the screen stays fixed on the Creality logo, as long as the printer stays on. A blue LED on the motherboard remains lit, permanently.

How do I know if my bootloader is potentially bricked? Or what am I doing wrong with my flash?

I hope to get an answer, thanks for reading,
Have a nice day!

Reddit post before I realized I had a GD32 chip; if it helps :
Hello, I can’t flash klipper on my Ender 3 v2 Neo. Here’s what I tried (When I talk about .bin, I call it something different than firmware.bin)

With Creality’s 8 GB microsd card :

** Put the .bin on the supplied sd card: screen frozen on “creality”. I waited 15 minutes.*
** Same thing, but unplugging the screen; I had no way of knowing if it had worked, apart from seeing if the .bon name had changed, which was not the case.*
** Same thing, but overwriting the card in FAT32 / 4096 byte*
** Tried to make a 1 Go partition : it doesn’t work*

Tried with a 32 GB SD card

** FAT32, 4096 bytes, “Creality” slpash screen.*
** Tried to make a 1 Go partition : same result*

UPDATE : I came across bootloader problems in my research: wouldn’t that be my case? How do I know if it is?

If anyone has any solutions to this problem :slight_smile: Have a nice day

I’m a supernewbie, so take what I say with a grain of salt…I’ve had simular problems with my ender 3 v2 neo. I have come to the conclusion my biggest mistake is reading the instructions. I don’t have it right yet, but at least made some head way. Where are you putting the sd card? instructions say take screen apart and insert card behind the screen… I got nothing. Instructions also say to load the firmware and private files again behind the screen… nothing… they also say to load the BIN file…yep, behind the screen. After LOTS of questions and you tubes, I have discovered If I load ONLY the BIN file into the sd slot on the front of machine ( nothing to take apart) I get some improvement. > I"m here now because , I’m not locked into Japanese… sigh… good luck

Thank you for your reply… We are in the same situation… I always put the micro SD card in the front slot. And I still haven’t had a chance to see anything other than the Creality logo on the screen. I think it’s crazy that Creality would change the chip on its motherboard (because yes, it’s the chip, a whole bunch of problems have happened with it) without saying anything on the site, especially as their support for it is catastrophic. Unanswered e-mails, questions avoided by chat, official firmware for the GD chip that doesn’t even exist directly on the download center… In short, after 6 days of agony, I’ve just bought a BIGTREETECH motherboard. I wish you good luck, and if I can be of any help, please don’t hesitate.

I wish u well… I struggle along here. I am know not locked into Japanese… LOL Only loading the BIN file at least acted like it was uploading something. The sites customer service has been lacking. Instructions are incorrect… what a way to run a business…
I’m stuck with this mess, This was a luxury purchase for me… I’ll keep peddling along I guess… hope for the best.

I have the same impression as you, really. Creality seems like a really nice company, with good quality products that aren’t too expensive… And in the end, no. Technical support and tutorials are lacking, as you say. It makes me want to warn people about buying the latest printers; this chip has caused trouble for many, just open Reddit. But it’s not easy, because the opinions/tests that come out when you download the Ender 3 V2 Neo, for example, all date from before the shortage, and don’t take this major flaw into account. In short, Creality is to be avoided. I find myself having to buy a 56-euro card, and I’m lucky to have them, especially as for me too, buying this printer was a luxury purchase.
I wish you good luck and, above all, good courage.