Charging the power on Ferret Pro

Hi, I began using my Ferret Pro today. Out of the box, it would show 2 green lights for power level. When I try charging it, nothing happens (it doesn’t charge). I could not find a video or troubleshooting guide to ensure I’m doing it correctly. Any guidance?

The handle is the battery. There is one USB C port on the handle that says in. Plug that into a charger. Are you doing it that way…?

Yes, that’s how I have it. When I connect it to a power outlet, no lights come on or blink to indicate charging and after 2 hours, the battery level is still 2 lights.

Try switching to different cables and power to see what happens… Not all these parts are created equal… :cry:

If I use the cord that connects to the PC USB, then I’m getting the flashing lights on the battery indicator, so that seems to work. That would imply that the main power cord with the 2 end ports is not working, which could be a problem if the camera unit can’t get charged.

I can’t find a single video or document that says what the lights should be doing during charging. That seems like a knowledge gap.

Well, @jimandyen, I was wrong about it charging from the laptop USB. After 24 hours, the unit still only shows 50% charge. I’m either doing something wrong or both cables are bad or the base just won’t charge. Any thoughts? I will contact Creality once they open on Monday, but thought I’d check with you (or anyone else here).

If I understand correctly you are charging the battery using a USB port from a laptop…?

I wonder if using a regular charger would be better… Like a plug in charger for phones. maybe the laptop pc is not supplying enough juice…? Just something to try…

Do you have one of these USB power meters?
Can you use the same setup that you use to charge your phone, so you know the charger and cable work?

I am using the same charger “head” that I use for my cell phone, so I know it works. I’ve added a picture so you can see the cable I’m using. It is connected to the “in” port on the scanner handle.

You might have already done this… Just for grins and to see if it works try this way with a regular USB cable hooked to a charger…

1 Like

Thank you, Jim. I didn’t have another cable, but the short cable for handset to wireless bridge worked. I noticed it had difficulty going all the way into the power “in” socket, but eventually snapped in. When I re-tried the actual power cable, it does not snap in, which is why it isn’t charging. I don’t know if it’s the cable or the inside of the socket, but something doesn’t fit correctly. Anyway, it’s a short charge cable for now, but at least it works. I will purchase a new cable that is a little longer. Thanks for the suggestion/resolution. - Mark

Great. Glad we were able to fix the problem for you.

1 Like