CR-10 Smart Pro Extruder issues

So I had to replace my sprite pro extruder on my CR-10 Smart Pro and now i cannot get it to level the first time. When I go to auto level my bed the extruder touches before the probe does. I changed my Z offset substantially and this did not help, it still crashes, PLEASE HELP

Hi @DBolyard and welcome to the forums.

Please double check that the probe is mounted to the hotend correctly and that the probe pin ejects when it tries to home to the bed.

Also double check that you have your offset set correctly and havent accidentally put a negative value instead of a positive value or vice-versa.

All things u have suggested have been checked , i have even adjust the hotend length from the extruder body to as deep in the extruder as i can . Still same issue

I would recommend starting the leveling process over and ensuring the nozzle height to the bed is correct by manually leveling the bed and then once thats done re-run the auto leveling. It sounds like everything needs re-calibrating from scratch in terms of the bed leveling.

I’m just fresh from dealing with an issue in this area myself.

What I have learned;
Your nozzle SHOULD be higher than the point of your probe (ie closer to the bed).
This means your z-offset should be negative…
To be honest I’ve no idea how the machine could be leveled if it’s not…there’s no way on mine to get the BL touch to drop lower during leveling, but the printer CAN apply a negative offset AFTER leveling to compensate for a nozzle that is “flying in the air”…this is what’s shown in the “adjust” setting.