CR Touch and Auto Bed Levelling not working properly.

Hi

Firstly let me thank anyone who takes the time to read or help. I’ve spent countless hours trying a plethora of things, none of which have worked. Whilst i cannot go into detail about the myriad of things I’ve watched, attempted or tried, the basics is I cannot get CR Touch ABL to print a bed level print without gouging my bed on the left side and being too far away on the right hand side.

I’ve got an Ender 3-Pro and in an attempt to resolve a little bowing issue I was starting to notice on the corners of bigger projects I purchased a CR-Touch.

I followed the guide in installing the CR-Touch, and after a false start after initially installing the wrong firmware (installed the firmware for Ender-3, not pro) and trouble shooting that for DAYS before I realised my mistake, installed the correct latest firmware from creality (GD-Ender-3 ProHW4.2.2SW2.0.8.2CRTouchFilamentEuropeMulti) checking the chip on my board does have GD printed on it. When I go into about this printer, it shows me;

Ender-3 Pro, 2.0.8.2, Creality V4.2.2 2022-11-09.

I tried to run the auto bed leveling (ABL) and noticed that the probe was functioning slightly differently to the how it behaved with the wrong (incorrect) firmware and was causing the nozzle to be pushed into the bed. I therefore installed some (4 on each screw) m3 washers to lower the probe a few MM to stop it mushing into the bed (knowing this will affect Z-Offset).

I’ve auto-homed the bed and then manually trimmed the bed with the paper technique, Z-Offset etc. The bed was as level as I could make it with paper. When this was done I ran ABL and it failed. When I watched the probe it was failing to make contact in the back left hand corner and this was obviously showing the >2mm error that can happen. I gradually adjusted the bed and ran ABL multiple times until it successfully passed the ABL.

When I ran the bed visualiser in Octoprint it was showing that the bed had a severe tilt with the left hand side of the bed just less than 2mm too low and the right hand side just less than 2mm too high. Using the Octoprint visualiser (which saves via M500 gcode) the mesh each time it runs I gradually flattened the bed to about a variance of 0.115mm from highspot to low spot across the bed. To recap, I’ve raised the left hand edge and lowered the right hand edge to flatten the bed based on the mesh data as visualised on octoprint visualiser. According to the mesh data, the bed is relatively flat.

I’ve re-run the ABL on the ender 3 to ensure it’s also saved the mesh and I’ve tried multiple different ways of slicing / inserting manual G-code into the start of the file. I get the same results. Tonight, having failed everything else, i’ve gone back to basics. I’ve taken the file and sliced with CrealitySlicer, used the SD card and started the print (OctoPi is dissconnected, removing any chance its my g-code issues in Prusa-Slicer, any mesh related shenanigans in Octoprint) and the exact same problem happens.

When I print, the left hand edge of the bed is FAR too close to the nozzle and is pushing into the print bed and no PLA is being extruded, when it goes to the right hand edge the nozzle is now too far away from the bed and is not really adhering to the bed well.

To Recap:
ABL runs successfully.
When printing it gouges into the bed, not allowing filament out on the left hand side and then on the right it too far in the air.

I was under the impression that ABL should make printing flatter better, I was getting okay results without ABL and have spent a few weeks working on this trying to get it to work to no avail.

Photos of the bed level when I first got ABL to work, then with it corrected based on the mesh data. Photos of the print issue.

Thanks again to anyone whose got this far and I’ll happily take any advice or tips on what to do next to get ABL to work enough to print a bed level test file.