CR10 S Pro AB Temp error - PID Tuning didn't work

This drama started several weeks ago now. The filament ran out mid-print and silly me didn’t have the runout sensor turned on. I had thought the nozzle was clogged very badly because I couldn’t get the remaining filament out with cleaning filament or a needle.

I happened to have another entire extruder as back up. It’s a sprite extruder. After I switched it out, I started getting the temperature error.

Over the last week, here is what I have tried:

  1. Old sprite extruder
  2. New sprite extruder
  3. Old sprite extruder with the hot end from the new one.
  4. Purchase brand new hot end, and tried in old extruder.
  5. New hot end in the new extruder
  6. Purchased a new Hot End Adapter Board. Put it on the Old Extruder with the brand new hot end.
  7. New adapter board on New Extruder
  8. Checked and rechecked ALL connections and wires multiple times in each step
  9. Went back to the Old Extruder and the Old adapter Board

So I have 2 adapter boards, 2 extruders and 3 hot ends.

When everything is plugged in, the extruder reads anywhere between 25-28C. Sometimes when trying to heat it up the temperature will rise and either start to fall or hold steady. The highest I have gotten the temperature to is 60C. Other times it won’t heat up at all.

I’ve had this printer about 2 years, so it’s well out of warranty.

Since I originally posted in other forums, I have downloaded pronterface and attempted to tune the PID. I got the AB Temp Error when it started to run the first cycle.

Where do I go from here in troubleshooting? My guess at this point is the cables going to the extruder, the connection of the extruder to the motherboard, or the motherboard itself.