Creality Ender 3 V2

My Ender 3 V2, has all of a sudden developed an error, when I turn the printer on it all seems ok until it gets to the main screen & just under the hotend symbol it just says err, if I try and heat the system up after a few seconds it making a bleeding noise and comes up heating failure :err & says to reset which I’ve tried. I’ve unplugged the thermistor from the mainboard and tried to start the system and it stays the same, I did read somewhere that if it stays the same with the thermistor unplugged then it’s likely to be the mainboard that’s at fault is that correct or will a new thermistor(which is on its way) sort the problem?

Hi @Colin_Boneham and welcome to the forums.

In theory a replacement thermistor should cure the issue. If the thermistor is faulty you will likely get the same error with it unplugged as its not detecting a temperature at all. Hopefully once your new thermistor is installed it should behave as normal.

1 Like

It sure has cured it, I’m sure glad the one I did read said the mainboard needed replacing after all

1 Like

Glad to hear that it fixed the issue :slight_smile:

New board(4.2.7 couldn’t find a 4.2.2) is installed, software(the latest version for the 4.2.7( says it’s for the sprite, but I have the og extruder not the sprite) downloaded & installed, but I think something ain’t quite right, the system heats up & then the head shots off too where it says the home point is then sits there for about 3-5 seconds & then says print is finished, when the print is meant to take about an hour for what I asked it to do, any ideas.

You ideally need to check which version of the board you have, there are 2 variants of board for the Ender 3’s, one will be STM and one will be GD, you can find out what chip you have by checking the large black chip near where the model of the board is stamped. Sounds like you may have the incorrect variant of firmware.

Oki I’ll have a look, this video is what it’s doing

It’s the stm32


Having re-looked at your initial image of the screen I am unsure that you have an Ender 3 V2 as the V2 has a colour screen not the blue and white LCD display.

If indeed it is a Ender 3 that you have and not a V2 then the firmware you will need can be found here:
Ender 3 Downloads and Firmware

The firmware that you should need from that page should be the
dated 24 Mar. 2022

Yea looking backwards at the creality webpage it’s not a V2 I was just goin by what the lad who sold it me said it was, I’ll grab the marlin firmware and give it a go n will let you know results

1 Like