Creality print crashes

Hey guys!

My Creality Print crashes everytime i want to slice an *.STL, it gets to 22% of the slicing in like a second, and then the blue wheel next to the cursor starts spinning and then the software crashes. I tried uninstalling it, and the installing it several times, but nothing helped yet. And when opening the software it says: “The software closes abnormally. wether to open the saved temporary file?”. No matter if I click on yes or no, it does the same. I have the latest version of the software, and I even tried older versions.

CPU: R7 3700x
RAM: 16gb

Hello @Nemo28:wave:

Welcome to the Creality Forum. Creality

Sorry to hear the slicer keeps crashing… :thinking:

Just some things to check:

Is it for all .stl files or just a certain one…?
Check your slicer settings and see if one is causing the slicer to crash.
Change the settings to default and see what happens…
Check the name of the .stl file. Some filenames cause problems.

It is for all .stl files. Since it is freshly installed it is on default settings. I’ll give other file-formats a try.

I’ve seen conflicts with windows causing programs to crash.
Do you have another PC just to see if windows is causing it.?

I tested it on a laptop, there it doesn’t even load the models. I tried other file-formats on my pc, but nothing works.

(translation from Google)
Hi all. There is a problem - the video driver crashes when opening the Crleality Print slicer.
System: Corei i7 3770/GA B75-D2V rev 1.0/16 Gb RAM/RX550 4Gb
On another computer - Ryzen 3400G, the slicer, after cutting the layers, loads the Vega11 video card by 100%. The system interface becomes very slow with friezes.
Is this a problem with the slicer or the hardware?

I replaced the slicer - installed an Orca slicer.
This slicer does not cause errors, but loads the RX550 video card by 80%. I can’t understand the reason for such a load on the video card. All tests and benchmarks for PC run fine. In games - no problems (fallout, wot, etc)

Another moment, I timed the time of cutting the layers. There is practically no difference between the Ryzen 3400 and the i7 3770, maybe a couple of seconds in favor of the Ryzen 3400.
All PCs use Windows 10 pro 22h2 and the latest drivers.

@Nemo28 & @IMaks_RS do you have these issues with all slicers or just creality? Creality is basically an older version of Cura so it would be interesting to see. Also, I was just informed of a new Creality Print update which can run parallel to the stable version. You may want to try that as it may address your issues. Just to be safe I would probably remove the current Creality Print to remove variables.

(Google translation)

  1. The problem occurs only with the Creality slicer + RX550 video card.
  2. I conducted an experiment - installed an old ATI Radeon HD7770 video card:
  • To do this, I first loaded the OS in safe mode and removed the current AMD drivers.
  • Turned off the PC, installed HD7770 instead of RX550
  • Turned on the PC and let the OS find and install the driver on its own. The Microsoft base driver was automatically installed. Then from the AMD website I downloaded the most current driver for the HD7770 - version from 2021.
  • Launched the Creality slicer - no problems with the application and video driver crashing. The load on the video card is no more than 25%
  • In the Orca slicer - the load is no more than 20% after completion of cutting layers.
  • Without removing the drivers for the HD7770 - I replaced the card with an RX550, I thought there might be a problem with the newer drivers. But alas, the application crashed again.

So far there is only one idea, replace the video card with an Nvidia one, released 2017 or later, and check the result.

Just to pinpoint more clearly: Were you ever able to successfully print using Creality Print with your GPU or was this issue from the start?

Your Rx550 is 7 years old which is a dinosaur by today’s standards and probably just can’t keep up. It may run other apps fine and crash on others. I’ve had that happen in the past.

Check out the benchmarks against my 3060ti here: UserBenchmark: AMD RX 550 vs Nvidia RTX 3060-Ti

Friend, please read carefully.
I installed an OLD video card - HD7770 purchased back in 2013!
And with this card the slicer works without errors!!!
Yes - today I carried out another experiment: the RX550 video card was installed on a board with an older chipset - H67. I installed my processor and memory on the same board. And guess what? Everything is working!
Considering that other slicers do not produce errors on all tested hardware, the problem is in the slicer itself. Somehow, miraculously, it works on the old hardware and does not want to work on the new one. Even if this “new” one is more than 11 years old.
The card you recommended will not fit on my PC. To do this you will have to upgrade. At the moment, this is not included in my financial plans for this year.

Glad it all worked out.

google translate

Me again )
In general… the week was fun… It seems I got to the bottom of the truth… and that was by accident. The problem lies in the AMD drivers… who would have thought.
With drivers from 2020 - the slicer works without problems, with drivers 21 and higher - the slicer crashes into an error. Here’s the thing.
Screenshots with versions are in attached files. The solution for now is to install the old drivers and the utility for adjusting the fan speed of the Fan Control. We adjust the operation of the cooler, because normally they do not rotate as expected and the video heats up to 80 degrees. Silent mode, allowing you to work at night - 47%, heating no higher than 62.
Naturally, first we remove the AMD drivers downloaded from the site and allow the OS to install the driver itself. The OS first installs the old driver, but then updates and installs the most recent one. You need to roll back the driver.
AMD driver ver error
AMD driver ver good

1 Like