Creality Print V. Appimage faulty Gcode

Gcode for above version of Creality Print has at least two bugs:

  1. It does not check to see if the extruder temp is correct before starting to print. Temp target remains at 0 for 30 seconds or more. Then it sets the temp to 238 but by then the print is ruined.
  2. When support is required it asks for confirmation to include support but does not actually add any support even in user indicates “yes”.

It is baffling to me that Creality cannot make slicer software that works for their own product.
Cura, on the other hand, works perfectly with this printer.

Hello @CrashedAgain
Welcome to the forum. Glad you could make it… :clinking_glasses:

From my experience with Creality Print the pop up message for supports is a reminder that supports are needed to print correctly and for the user to configure the supports options in the slicer or manually. When you click yes it will wait for you to add supports.
If you have already configured the slicer to add support you shouldn’t get that message…

I haven’t seen this problem using Creality Print. I configure the temp settings I want in the slicer using a K1 Max…

Re: Supports
When I click on “add supports”, one would think it would add the required supports, but it doesn’t. If it expects me to somehow configure the supports, there doesn’t appear to be any way to do that. The only relevant settings are under the “tools->Manage printer” menu and the only mention of supports in any of the sub-menus in that pop-up are “support line width” and “limit support retractions” under the “extrusion1” tab.
Apparently there are supposed to be more options under “Advanced” but selecting Advanced does nothing.
Starting Temperature:
Under the G-Code tap there is a “Printer start of G-code” entry that says
M140 S0
M104 S0
According to hpps:// marlinfw/docs , that means
“set bed temperature to 0” and
“set hotend temp to 0”
That is followed by
“StartPrinterExtrusionTemp=[material_print_temp_layer_0] …”
which would seem to indicate to set the temp to whatever is set by the slicer
BUT in practice, the target temp does not change until the printer has tried to print (with a cold extruder) for about 30 seconds.
The only workaround is to preheat before starting to print, which you should not be required to do.

Trying to understand how it works…Is this the menu we are looking for…?

I don’t have that screen. Only this one:

What version of Creality Print are u using? And what OS?

actually here is the entire page…

Sorry took so long to answer…
This is from Win 10 Creality Print V4.3.7.6619

Click where the green circle is. Make sure advanced setting switch is on… :stuck_out_tongue_winking_eye:
That will be the menu for all the slicer settings.

Ah-ha! There it is!
Thank you!!!
Hopefully all will go better now.

You are quite welcome sir… Have fun… :star_struck:

Support is now working, but temperature still is not working like it should.
Initial printing temp is set to 230, so it should wait until the extuder comes up to 230, should it not?
But - if I start print with a cold extruder, it still immediately starts trying to print without heating the extruder.
If I preheat the extruder, it starts printing right away, but it does not maintain the extruder temperature. I have to manually set both the extruder temp and the bed temp. The settings from the slicer do not kick in for 30 seconds or more. Looks like maybe it is waiting until the first layer is finished.
What am I still missing???

That’s strange. After I send the gcode to the K1 Max printer and then click on it to print it does the nozzle clean and all that. Then it sits in the corner and waits for the nozzle temp to go to my setting of 220C. I usually preheat the build plate but it waits.

That’s what I expect it to do! But it doesn’t.
Perhaps it is a bug in the appimage version.
I thought I saw another post here with the same problem but I can’t find it now.
When you look under Tools>ManagePrinter>G-gode does it show a “Printer Start of G-code” entry?

I’ve seen the start G-code before. Can’t remember where…
I don’t know enough about G-code yet but if you click on “G-code” on the right side of the screen. I don’t know if that’s what you mean though…

It is under main menu item “Tools” , then “Manage Printers” then under the “G-code” tab on the pop-up screen.
M140 is the g-code command for set bed temp, M104 is set extruder temp.

Curious if your coding is different…

Found it. Thanks… Nice.
Yup. Mine is the exact same…

The I wonder why yours can start from cold and mine won’t.
Must be some setting somewhere…

I’ve done this a few times but try resetting your printer back to default. (Uncheck boxes about logs and others so it won’t erase them) You’ll have to rebind it again to Creality Cloud. Also reset the slicer so all the settings are back to default. There might be a setting that is off we forgot changed… Maybe…?? Just throwing out ideas here… :stuck_out_tongue_winking_eye:

Tried that - deleted the config file so it had to write a new one. Not using the cloud.
Still tried to start printing cold.

I changed the “M104 S0” to “M109 S200” (set temp to 200 and wait until temp is up) and it worked.
So I changed “M140 S0” to “M190 S55” to heat the bed.
Might also add “G28” which is “home all” …
Questioning why it isn’t set up that way by default and also why it worked properly with your default settings but not with mine, but I guess we’ll never know.

Pleased to get it working, didn’t want to have to switch to Cura. Cura is a good slicer but it doesn’t get all of the Ender 3 SE stuff right so it will only print about 50% as fast.
For what it’s worth, the SE is replacing an ANET A8 which I have had for a few years. It is a much better printer (an understatement if there ever was one!) and is about 5 times faster, plus all sorts of convenient features.

I don’t understand why it would be different unless you bought it used…??

I have the temps I want in the slicer setttings… That should tell the printer to wait… right…??

New printer, and of course new Creality Print program.
Yes, it should tell the printer to wait.