Cura can't send wireless print files to Sonicpad

I’m a new guy to 3DP but I’m above average to networking and hardware. I setup Cura with Moonraker and listed my IP and wasn’t able to send files to my Sonicpad thats hooked to my Ender 3 S1 Pro. I attempted to add port 7128 and I’m still getting the same error. I get error connection to moonraker at http://xxx.xxx.xx.xxx:7128, and a prompt that says check your Moonraker and Klipper settings, a firmware restart may be necessary.
I’ve tried with a port and without and still have no luck. Any help would be appreciated.

Hi @ChuckNorse and welcome to the forums.

Usually you would access the Sonic Pad/Printer via the IP address only, there should be no need to add a port number as far as I am aware. Using the moonraker port wont work as moonraker is the backend communication layer of the printer and not the part you interface with, the part you interface with is Fluidd. On the Sonic Pad there is usually no port number required to access the Fluidd interface as its the default UI for the web side of the Sonic Pad.

Hope that helps.

Is there a good place to find a walkthrough on how to setup wireless transfer to the Sonicpad from Cura? The previous videos I watched showed Moonraker. Also, it seems my Sonicpad is very picky in the USB cables used to attach to my Ender 3 Pro and my Ender 3 S1 Pro, is that normal?

Thank you for the help!

Usually you would just enter the IP address of the Sonic Pad, no port number should be required.

To find out the IP address of the Sonic Pad you would usually go to Configure > Network Settings > choose either wired or wireless depending on how you setup your Sonic Pad, your IP address should be displayed.

If you are still unable to get Cura to talk to the Sonic Pad then you may need to enable to root functionality on the Sonic Pad so that Cura can communicate with it.