Display on my 3D printer remains stuck on word 'Creality'

Hello everyone

despite the fact that the printer worked as a charm last week, today I turned it on to do some further printing and the display remains stuck on the word ‘creality’ and refuses to show the print / options menu.
Nothing is connected to the printer, no SD card is in and no firmware upgrade has been performed. The fan is running but apart from that nothing happens…

I looked up some information on the internet, but nothing conclusive was found.

Can somebody guide me into the right direction to get this solved?

tks + rgds


1 Like

I would recommend grabbing the latest firmware for your printer and installing it to your printer. Sounds like the configuration files or firmware files may need refreshing.

1 Like

Good advise Nikoli and I proceeded in this way this morning. Unfortunately the printer doesn’t read the SD card on which I had put the files. I even left it in for about 45 minutes without something happening. I even tried another SD card thinking it might be a defective SD card (although it had worked flawlessly putting the sliced files onto it) but with the same result.

Having said above, the printer (which has now been in my possession for about 4 weeks) behaves erratically during this entire period. Sometimes it can connect to the raspberry, sometimes it doesn’t with now the latest one being a) it can’t see the connection port and b) it remains stuck on the startup screen.

It looks to me as if the motherboard is hicking up and needs replacing. I contacted Creality support with a short movie of the startup of the printer and they claim they referred it to a shop technician to help with the problem.

I can only hope this can be solved to my satisfaction in a reasonable period of time.

B rgds

1 Like

A couple of things worth checking…

Firmware flashing…
Check that you formatted the SD card as FAT32 with 4096 as the allocation size.
Be sure to also rename the firmware file to something like Firmware.bin or 123.bin as if the name is too long the printer wont read it.

Raspberry Pi…
You mention using a Pi… I would recommend taping over pin 1 on your USB A cable that plugs into the Pi as follows…

This will prevent the Pi from supplying 5v to the printer/screen. Often the 5v feed from the Pi can interfere with the way the screen and printer boots.

Hope that helps.

1 Like

ok … filename rename … didn’t do that … will do so and give it a try … thanks

pin1 was already taped and it worked correctly … sometimes …


1 Like

noope, renaming the file does nothing at all. Printer doesn’t read SD card. I become more and more convinced it is a faulty motherboard that is causing the problems

1 Like

If formatting the SD card correctly and renaming the file did not work then double check you are actually using the correct firmware files for your printer.

If all else fails I would recommend reaching out to support to see what they can suggest for you.

I used yet another SD card (newly purchased), formatted it and put the files on it and now it flashed the firmware and the menu is back on.
I am wondering whether the previous SD card was suitable for this operation.? It is an micro SD XC card, whilst the one I purchased today is a micro SD HC card??

Perhaps above is the explanation why the card wasn’t read by the printer…

Thank you all for your kind assistance in this …

1 Like

Glad to hear you were able to get the firmware flashed ok. Some SD cards do seem to act odd sometimes but I have used XC cards without issue before. Just glad you were able to resolve the issue :slight_smile:

indeed, although I used a microsd card from sandisk, I should have noticed that it is not entirely ‘compatible’ as it seems.
One indication that should have warned me was the fact that I had to use an additional program to get it formatted to fat32. When inserted that card only gave me the options ntfs or extfs…
The card I successfully used to flash the firmware didn’t present me with this problem but instantly gave me the option fat32…

It may (or may not) help other members in the community if they run into a similar problem.

Thank you again for the kind assistance in this

1 Like

Yep, if I remember correctly any cards over 32gb in size will not offer FAT32 as an option by default as FAT32 has many limitations including file size limits of 4gb.

I think you hit the nail …

1 Like