Ender 3, Blue Screen of death

My ender 3 has suddenly gone to just a blue screen on start up, so far I’ve switch it off left it overnight and restarted it again, unplugged it and left it over night and plugged it back in to start up, I e checked the lcd screen cable at both ends is in the port solid and correctly, I’ve started it up with no sd card in, started it up and then pulled the sd card out, all to no avail it just goes to a blue screen, the last time I used it, it was fine printed ok and was shut down as norm and then the next day blue screen, any ideas ? Also does anyone know of a local to Telford Shropshire, where I might be able to take it if all else fails?


Can we have a bit more information please?

Is it the stock bare bones metal frame screen? Or one of the better screens?

If it’s the basic metal frame screen attached directly to the frame and doesn’t have a non conductive spacer, this may be your issue. Sometimes it’s too late and the screen can’t be saved. I had a screen last 2 years with no spacer to stop high voltage circuits grounding through the screen. Then one day, blue screen of death.

If you have a different screen that has a plastic mount, or your basic screen has been properly upgraded with a plastic/printed mount, this is obviously not the issue.

Possibilities are the obvious screen failure, or a firmware issue.

If you have a basic screen, try upgrading the main boards firmware. If you are on the newest firmware or a custom firmware you don’t want to change, try reloading it. The board has no concept of newer, older firmware. It will flash any firmware file. If you are reflashing the same firmware, you will need to rename it. You can name it whatever you like. To make it easy I just use “firmware.bin”. It has to have the .bin extension on end of name to be recognized as a firmware to flash board with.

If you have a newer style screen, you can still try a newer board firmware first. It can produce the same issue. Additionally you can upgrade the screen firmware as well on screens with the SD card input on them. Find the correct firmware, if it’s the same as you have now, rename and reboot to flash just like the board firmware update.

If none of this helps and you have checked cabling correctly, it sounds like the screen has expired.

It’s just the stock screen, it’s never been replaced as long as I’ve had it, I got the machine second hand, if I tried to do an update on firmware there is nothing showing on the screen to see what it’s doing, but I will give it a go as anything is worth trying at the moment from where I am.

Okay…. Before you go through all the firmware stuff, turn off printer and unbolt the screen from the frame. Leave cable connected! Don’t let the screen frame touch the printer. Turn printer back on and let me know if anything has changed.

Nope made no diff still blue screen

Okay…. I’m guessing no one you know has a screen you can just pop in and check it???

Next step would be trying new/reflash firmware in that case.

Unfortunately the main board is also a possibility.

What part of this big blue marble are you from?

Sorry, I see you already answered the where you are from.

I’m across the pond. Bummer, I still have a 4.2.2 board and original screen somewhere around here.

Do you know anyone who would be willing to let you test their screen on your rig???

It would need to be same model screen to work without changing firmware on your board to match/be compatible with a newer/upgraded screen.

Yes my son has the exact same printer but he has it use at mo, when he has finished with the job it’s doing at mo, I’m goin to see if his screen works on my printer if it does then it’s gotta be the screen if not most be down to the mainboard or cable at a guess

If it ends up being the screen, there’s a very good chance it damaged due to higher amp/voltage circuit grounding through the screen. I recommend you installing a non conductive adapter. It will help a lot with making the next screen last longer and not show a garbled mess when it is working.

You can 3D print this:


If the auto mod removes the link I pasted above just go to printables dot com and search for ENDER 3 SCREEN SPACER. It will pop up. Download and print. Easy install.

Thank you I’ve got the link & the mod I will get printed off for both mine & my sons machine to save him having the same happen to his, his is still printing at the mo so I’ll update later

Finally got to switch lcd screens today mine works on my sons printer, but his doesn’t work on mine, so it’s down too the cable or main board now, cable is the next easiest to try out

Did the check with cable today, looks like it’s a new mainboard

I have the same issue as you.
How can i check if the mainboard is really the issue?
With a multimeter for example?

I’ve changed the cable to the lcd & used another lcd on my printer and used mine on the other printer to no diff on mine n mine ok on the other printer so I’m guessing it’s a mainboard fault now, I also tried the firmware update it no joy & yes a multimeter may find the issue but where to look I’ve no idea, it could be a blown cap or resistor, I’m going to replace board and then do a fault find on the old one, crossed fingers it works

I found the problem, it’s a cable that comes from the sprite extruder. The cable shoud not pluged in then it works.

I’ve got the og extruder on my ender 3, so I’ve not got the sprite extruder

While looking for a new version of my mainboard I’ve come across the Bigtreetech version 3 board which claims to be for the ender 3, but is it or is it too good to be true, anyone had experience with the board or shall I avoid like the plague, which is my gut feeling.

This is it….

£28.19 63% Off | BIGTREETECH BTT SKR Mini E3 V3.0 Motherboard With TMC2209 UART VS SKR 2 3D Printer Mainboard for Ender 3 Ender 5 Pro CR 10

Not sure how far you got with a new board if you decided to try it. I’ve been busy and didn’t notice your post here. I don’t have personal experience with the big tree boards. Ali Express can take forever sometimes. Between my friend and I, the customer service has been pretty bad with that company. Your experience may be different.

Have you gone through any initial testing that Colin has? The same issue doesn’t mean it’s the same point of failure. As you see in Colin’s case, it turned out to be something else.

You can try accessing the board with printer turned off and unplug one connector at a time to eliminate anything else in system causing the issue. As you unplug each connector, fire up the printer. See if anything changes with each connection. If it does, we know it’s that area. Then we can check cabling and the rest of that circuits parts to track it down.

If you decide to or find you must change the board, why not go with the upgraded Creality board? The 4.2.7 is a great silent board with multiple upgrades. It will feel like a new printer. You won’t believe the difference. And it quiets the machine down tremendously!

That way in the future you still have a complete system you can come here for help on. No searching for help in multiple forums with a printer using multiple manufacturers parts.