Ender 3 Max Neo cooling nozzle during filament change

I’m trying to do a filament switch mid-print for a color change and having trouble with the behavior of my Ender 3 Max Neo. I can manually pause the print using the control knob and change filament and resume the print. But this requires me to inconveniently catch the printer at the exact second where I want to change color.
I have tried the different iterations for adding G-code extensions in Cura and Creality Slicer (Pause at Height [M0] - Filament Change [M600]) and maunal editing of the G-code. These do work at stopping and resuming the printing if I do not remove the filament (!!).
BUT … if I remove the filament for a change, the filament detector triggers either a ‘out-of-filament’ error or ‘Homing XYZ - please wait’ (apparently forever!). Either of these cause the nozzle to immediately start cooling down - and it doesn’t heat up when the filament is replaced. That detector does not cause such problems with a manual pause. How can I get around this problem?

Hi @JDPmilton welcome to the forums.

I would recommend trying to run multi colour prints bypassing the filament sensor, if you do not want to disconnect or disable your sensor you can just place a short length of filament in the sensor to keep it happy during the print. This may prevent the printer complaining about the lack of filament.

I could not get M600 added by Creality Slicer 4.8.2-291, so I manually added it to the gcode file. However, my Ender 3 Max Neo just kept printing. I had to manually pause. What version of firmware do you have installed since yours actually stopped at M600?