Ender 3 Max Neo + Sonic Pad Not working

Hello.

I bought a Creality Ender 3 Max Neo FDM Printer + a Creality Sonic Pad.

I read on the official website and also in the forum its compatible each other.

My Printer Motherboard has a GD32 Chip type. I cannot find anything like that on the Sonic Pad where I need to choose the right printer for the firmware setup. I tried everything I can and I also tested nearly all printer in the list but none of them works. I seen many Reddit issue about this, but 99% of the issues the final solution was to replace motherboard or buy a new printer.

Im really angry about this issue because that was a Christmas gift and also because the description tells it works perfectly with my printer doesnt matter which type of motherboard I got.

Please if you found any workaround how to make it and can write some steps to try it would be really appreciated.

Thank you very much and have a wonderful holiday friends!
Gery

Hi @colethegamer and welcome to the forums.

If you have updated the Sonic Pad and the printer is still not available you may need to use a workaround such as the one at the following linkā€¦

Creality Ender-3 Max Neo and Sonic Pad

Due to the global supply issues with some electronic components the MCU chip was changed which may be why you are experiencing this issue. Hopefully the link above should have all the info you need to configure the pad with the printer.

Tried but also not working if I choose V2 because that is also wrong chip version I think so.

In that case what should I do if the official website wrote in description my printer is supported and bought also from Creality and still not working? Refund?

Thanks

I would at this point recommend contacting customer support as they may have a firmware that they can supply you with that will resolve this issue.

Exactly what I did a few hours ago, of course their Customer Support just copy pasted the tutorial how to turn on the device and select my printer even if I told them its not my issue, the problem is on their side with the firmware or the missing parameter, so they opened a ticket and maybe a technician will answer in future. Thanks for the hints, it was worth a try. <3

Support will always generally send you general troubleshooting to begin with and if that doesnt resolve the issue then they will usually escalate the ticket to the engineering team for further analysis. Bear with them and they should get back to you with a more detailed response.