Ender 3 Neo - X axis stopped

Help, I had an Ender 3 for years until it died and i bought another ender 3 neo

Was working fine until mid-print it just went back and forwards on Y axis and stopped.
Now the X axis does nothing, iv swapped the plug to a different motor, ive changed the limit switch, updated the firmware, followed all the cables and everything is plugged in.

I can get one very slight jolt from the motor and that’s it. Im at a loss

Hi @Matt_Clark and welcome to the forums.

It sounds like your stepper motor has failed. I would recommend reaching out to support to see if they can send you a replacement stepper motor if you are still under warranty. If not they should also be able to point you in the right direction to obtain a replacement stepper. Good luck!


When you say you swapped the plug to different motor, did you do it on the main board side? Or on the end of the cable that attaches to the stepper motor?

If you did it from the stepper end, still have onemore hoop to jump so I can help.

Please try swapping the Y axis with X axis plug on the board. Unplug machine first! After rebooting the printer, do not go through “homing”. Go to manual movement of axis’. Try both the Y and X axis’ with 10-20mm movements in both directions. This way it doesn’t try to beat any axis against end travel while “Homing”.

If the Y axis is now the NON functional axis, you have still not eliminated the cable being an issue. Even though you plugged the cable into different motors, if it’s starting to break internally, it may run the other motors when moved in different position. If the X axis is still inoperable, you need to go 1 step further to complete diagnostics of hardware problems.

There are still other possible causes.

1- The firmware has been corrupted on the printers board. Not the most common problem. But if Y axis now has an issue it is a possibility. I know you said you changed your firmware. Sometimes you think you did if your using same firmware and tried re flashing it. Try downloading a newer firmware for your printer from creality. Stick to stock firmware for now if you run a custom at the moment. If you already have the newest firmware, re install it. You will need to rename the firmware on SD CARD for it to work. The board has no concept of newer/older firmware. It will flash any firmware as long as it doesn’t match the name of current firmware. This is why you need to rename it. You can just call it “firmware.bin” or a name of your choosing. The only requirements are it has to end in .bin, lower case and no other firmware or print files on the SD CARD. Just the “whateveryounameit.bin”. The other file that’s always on card, leave there. I have all my “hidden” files visible. You may not even see another file.

2- The driver on main board has failed. It’s a mechanical driver. There are multiple things on the board that could also cause the driver not to function. Unfortunately all of them would require electronic diagnostics and repair. It’s cheaper to buy another board. I repair electronics and work in electrical engineering. Unless you or a friend does as well, repairing the board just isn’t cost efficient. I know you said you swapped connectors to different motors. But didn’t specify from which end. If you have already tried the X axis on different motors and are positive the cable is fine, the board is most likely okay and this isn’t an issue.

Side note on #2! “MOST” mechanical drivers are killed, not fail on their own. I would OHM the X axis stepper motor and compare with other motors to see if there is a significant difference in ohm readings unplugged. If there is, it’s possible the motor was initial cause of failure. Just because it works plugged into another driver socket (swapping cables on the board), it doesn’t mean it’s a good motor. It will in time damage another board if it’s pulling too many amps.

3- The MOST LIKELY CAUSE is the X axis stepper motor. Have to replace it.

Let us know what steps you take and how you make out so it helps others who happen upon this thread looking for help please.

Hey Nikoli,

I changed a few different motors and still nothing


Yes i tried a few different motors and nothing, swapped out the X and Y plugs on the board and the X axis motor is fine.

I did the firmware upgrade, and still nothing. I

I replaced the cable from another printer and still nothing so I guess that means the board is no good.

I did try to check the Ohm on the steppers and the one that’s not working has less resistance than the ones that do.

The printer is less than 48hours old.

Thank you for your reply

Okay, the motor is good.

Try 1 more thing please.

Before the seller sends you any part under warranty, they will run you through the same steps anyway. This way you can clearly explain how you diagnosed it. It will save you 10 messages back and forth.

The last thing to try:

It’s a bit unclear so I’m not sure you did this step.

On the board side, plug the Y axis cable into the X axis connector. If the issue now is on the Y axis stepper motor, it is absolutely the main board.

Let me know if you have time please.
That way anyone with similar issue has a complete diagnostic direction to go through. If people are out of warranty, this will help them save money and time wasted on just purchasing an X axis motor they do not require.

Thank you,
Wil…. Superman not necessary, lol. It’s an old nickname from childhood and baseball.

System here said I’m too new and couldn’t create another answer to you, lol.

I had to edit this to say great!!! We beat the machine!
A win is a win my friend

Thanks Will,

I replaced the board with an old one and works mint.

You’re a champion :smiley: