Ender 3 SE "Lost connection with MCU" Sonic Pad AND BTT Pad 7

Printer- Ender 3 v3 SE, AND Ender 3 v2. **The Ender 3 v2 works flawlessly, printers great 0 issues. it’s only the Ender 3 SE.

MCU- Tried both Sonic Pad, fully updated with stock installs from the pad. AND the BTT pad 7 with stock klipper. Issues present itself on both MCUs, however, it is MUCH more prominent with the Sonic Pad, which unfortunately is the MCU I would like to use.

Issue- Getting “Lost communication with MCU” typically directly after the printer auto homes before starting a print. I have had 2 prints actually start, but shortly into it. 5ish minutes loses connection. Seems to happen after the hotend heats up, but before the bed heats up, between the 2, the bed homes, and it drops 90% of the time there.

I have reviewed this link many times-Timeout with MCU / Lost communication with MCU

Other information- on the Sonic Pad it wants to use the GigaDevice GD32 architecture, which only supports serial connection through the LCD port. On the BTT Pad 7 I can use the STM32 architecture which allows for USB-C to USB connection.

Even when I modded my own firmware to connect to the sonic pad with the STM32 USB connection I get the same results, with the connection issues.

The issue persists regardless of connection type it seems.

What I’ve tried-

  • New serial cables, 3 of them to be exact with no change.
  • Different USB ports on the Sonic pad, all have the same result
  • Lowered print temp as a test, no change
  • Remove other USB devices
  • Purchased a BTT Pad 7 to test it with native/stock klipper, similar results, although not as frequent.
  • Tried both architectures STM32 and GD32 compatible with the SE board for different connection types, no change

What I believe is ruled out- Both printers are plugged into the Sonic Pad, via serial. 1 works flawlessly the other doesn’t.

  • Inadequate / over-loaded power supply of either the host or the main power supply
  • Loose connectors / crimping connections or damaged cables
  • Incorrectly powering the printer board over USB instead of the main power supply or supplying power simultaneously via USB and main power supply (No USB to USB connection)
  • Other USB devices, e.g. webcams, hogging the USB communication ( no other devices like webcam are enabled/plugged in)

Why I want to use a Sonic pad over RPi/BTT-

  • features I can’t find anywhere for klipper, Power outage renewal, AI detection, Link to the Creality cloud.
    • Yes, I know with like octoprintereverywhere and others I can get AI detection for free/$ and get cloud support. I have not seen any promising power outage restart projects.
  • Don’t plan on running more than 2 printers. If I do I may change to RPi

Things left it may be?-

  1. Hardware issue on the printer board itself?
  2. Issues with configs, or other files on the Sonic pad? (other report the stock SE works great out of the box, so seems unlikely)
  3. I ordered 3 bad cables from Amazon? (however, the cable that the Ender 3v2 uses works flawlessly, tried that cable to the same result)
  4. ???

Both are brand new fresh stock installs from the Sonic Pad-
klippy log from the last to test prints-[ERROR] 2024-06-24 20:46:46,465 [root] [virtual_sdcard:_load_file:416] File open - Pastebin.com
Printer.cfg from said tests-# !Ender-3 V3 SE# printer_size: 220x220x250# Version: v1.2.0# CreateDate: - Pastebin.com

If there is anything else you need to point me in the right direction let me know. At worst my return policy date is coming up and I’ll just ship it back…

Thank you!

When my Sonic Pad gives me key1 errors and lost connection to MCU I partially cured it by a new USB cable to my Ender 5 plus, it had a bent end and plugged the Ender 3 V3 SE into one of the rear USB connections rather than the side. Seems much happier like that. Might want to look at a new USB to Serial cable too.

Thanks for the reply. I have tried 3 different serial cables, but none seemed to help. They all work perfectly on my 3v2, just not the SE

I can do anything else on the SE BUT print. I can run all the calibration tests without a single disconnect. When I go to print, BOOM disconnects.

You’ve tried all 4 USB sockets?

Yes, and removed all other devices, such as webcams. Both printers are connected, the 3v2 works flawlessly, the SE doesn’t. Switched cables, switched ports, and nothing seems to fix the problem.

Double checked that the knob display ribbon is properly seated into the motherboard? Don’t know how available that cable is, just in case that one is the problem. It is a bit of a shonky chain of cables. Be nice if there were a single cable from mobo to USB. Fails on both BTT and Sonic Pad, feels like that final link in the chain is that cable.

I will check that.

fails on the BTT were less constant than with the Sonic Pad, however on the BTT I was using the USB-C connection, not the LCD ribbon cable.

Do you know of a way to use the USB-C connection on the sonic pad? In the stock config it requires the use of the ribbon cable. however, I compiled my own config and got it working on the sonic pad with the USB-C cable but that didn’t fix the issue either.

Secondly, could there be some code in the config or something else causing issues? I investigated the baud use with the SE on the sonic pad and its abnormal but changing it doesn’t fix the issues. Is there any other software setting that could be at play?

Surprised by that I thought the USB sockets on the printer were disabled once the Sonic Pad was in play. Running out of suggestions.

Well, I re-glued the ribbon cable to the motherboard, to make sure a good connection, however the same issues.

I can troubleshoot, run esteps, and calibrate anything, but as soon as I print, boom connection issues. Maybe something in the coding? idk I’m at a loss as to what to check next.

shot in the dark, based on a post elsewhere, but taping over the 5V pin, presumably on the serial end


Pins 1, 3 and 4 only should be connected. I think I have a better diagram somewhere. So tape over pin 6.

it was on Reddit

Or a USB power blocker dongle find them on Amazon too probably.

I had done this in the past, and admittedly forgot about it. I followed this guide

however, it did not make a difference for me.

Overkill but another motherboard? Really can’t think of anything else…contact customer service for a new board/new printer?

Yea, that is where I am at too, I reached out to them last night, just waiting for a response.
Thank you.

did resolve my issue, and it’s pretty stupid to be honest. The voltage switch at the back of the printer was set to 220v, while I’m in the IS and we use 110v. Flipped the switch and boom, fixed.