Ender 3 V2 black screen

My power died during firmware update, I think is what happened, this unit has been sitting around for awhile and I want to try to save it.
I can format a drive and put the firmware bin on it and the unit powers up, but the screen (though obviously having power) has a blank/black screen.
I tried flashing screen with that firmware but nothing seemed to happen.
My card is only 16gb and I tried shortening the file name but nothing.
Can I save this unit?

Which firmware versions did you use for each?
The 16GB card is formatted in FAT32?

I used GD-Ender-3 V2-Marlin2.0.8.2-HW-V4.2.2-SW-V1.0.4_E_N_20211230 (for the printer, I don’t recall what I tried to use for the screen)
I was careful about the board version 4.2.2
The 16GB card was formatted in windows as fat32, I just double checked it

Trying again (because my Kobra 2 is down don’t buy one) with a freshly formatted 8GB drive no quick format, as FAT32, … and it didn’t work. Why? Because I made a MISTAKE!
My mistake that you should not make is that the card had a second partition that I didn’t notice! After putting the BIN on both partitions, it worked!