Ender 5 pro bl touch set up

So I have had the printer a while. Could never get the information from customer service that i could understand so gave up. I have a 1.15 main board and an original marlin.
I have the bl touch installed on the printer .
Now the problem connecting the cable from board to desktop computer. When i do i get the units probe to go in and out and board has light As is the printer screen.
When i open the software i can’t get the list of files to show up ( like amica1984p)
No idea why?
I did get it to work once and had it read and write the file per the instructions.
Then it asked to open the hex file. But when you click on it the file manager opens and i have no idea where to look for the hex. So i can’t update the software to make it work.
Any help would be greatly appreciated as thIs is a problem that has been driving me nuts for 3 years.

BL touch cable plugged into the correct pins on the motherboard? I accidentally connected mine wrong once and it wouldn’t work correctly. Tried a different cable to the desktop, that might have broken.

Thanks for the reply, I figured if the power was on it was right. It may have been at an angle the time it worked will try that again.

If it did read and write the info where would that data be kept on the printer?
Worse case i could move files to an SD card and have it load that way no?

Try the SD card, why not, nothing ventured nothing gained. My BL touch was connected on one of the next rows of pins on the motherboard, my fault for being partially sighted.

I would if i knew which files and where they are located. Especially that hex file that was saved. Thanks again for the help

I am trying to decipher your post… I am assuming you are attempting to connect the printer to your computer using a USB cable in the hope that you can control it and send the files to it??

The only proper way to accomplish this would be to either add a wifi box to the printer to enable file transfers etc wirelessly or you could add a Sonic Pad. Afaik you cannot communicate with the printer via a slicer software as the printer does not have this functionality. It can however usually be communicated with using something like Pronterface but this is more for diagnostics/testing.

Thank you for the reply.
I am trying to get a BL Touch to to work. I have it installed on the printer.
But getting the firmware installed is the issue.
The cable that comes in the kit (ISP pin board and burner) that goes from the main board to the USB port on the printer seems to work as the board lights up as does the control panel and the probe goes in and out a couple times.
The problem is when I open the PROGISP program I can’t get the box where you select the chip to list any most of the time.
I did get it to work once and entered the ATmega1284p as the indicate in the directions.
Was able to set the low value , hi value,ex value and then write it. then close that window.
But then they says load Flash —> Select hex file
When i hit load flash it opens the file explorer for the entire computer so i have no idea where to fins the hex file.
When i wrote the values was that saved on the board or the desktop?
Sorry this a real pain in the butt.

Ok I think I understand what you are trying to do now… you are trying to flash the firmware to the printer?

If so you do not use a computer, you would usually place the firmware files on an SD card and insert the card into the printer and power on. The printer will receive 5v of power if attached to another device via USB so it is not recommended to have a USB connected when flashing the printer via the SD card as it could cause issues.

The firmwares for the Ender 5 Pro can be found here:
Ender 5 Pro - Software & Firmware

Here is an example of how to do a firmware update:

Mainboard firmware update:

  1. Format the TF card on the computer side, and select 4096 for the allocation unit size.
  2. Put the firmware file Ender-5 ProMarlin2.0.6HW4.2.2GDBLTouch.bin into the TF card.
  3. Turn off the printer and insert the TF card into the card slot on the motherboard.
  4. Reboot and wait for the update to finish.
  5. After finishing the update, remove the TF card from the motherboard slot and delete the bin file inside.

thank you again for the help. The box that the BL touch came with had the USB boot loader cord with it.
So I finely got it to hook up and flashed something as it went through its upload. But now i have a brick. When i turn it on i just get the Ender Logo with white background.
Will what you have listed on you last post fix that also by reloading the whole thing?
Also what you are recommending is for an 8 bit board? The last version of Marlin for the 8 bit main board was like 1.9 or something does 2.0 work for both 8 bit and 32w bit?
Wish i got your post before screwing it up more.

Just so you have all the info on the printer
Ender 5 Pro with V1.15 main board 8 bit
had Marlin 1.18 firmware from factory
the BL Touch is also creality unit smart V3.1
I want to be sure that the link you gave me will work with this Printer and BL Touch combo.
Also will the SD card load on it now that i screwed up the existing firmware on it?
I really appreciate your help.so much

I have tried to do some digging on the installation of the cr touch on a 1.1.5 board and it seems that you need to hook up the touch probe using the split cable and then you have to flash the firmware supplied usually using the SD card.

If you need the original firmware for the 1.1.5 board (v1.1.8) at any point you should be able to retrieve it from here:
Creality Cloud - Ender 5 Pro Firmware Downloads

Your awesome, thank you so much!
By the split cable that would mean that usb able that came with the full kit?
That hooks up to the six pins to the left of where you stack the small board that the bigger cable goes in?
Is the other firm ware Below going to work with my set up?
The firmwares for the Ender 5 Pro can be found here:
Ender 5 Pro - Software & F
I have a few SD cards so can put the original on one and this on another to see if that works? Thanks agaIn for taking the tIme to do this.

So i down load that file and translated the instructions. They say to use the usb cable?
Sorry just want to get this right since have only done it the time i screwed it up ? this is the instructions:
About Ender-5TMC2208 Silent Driver USB Data Interface Direct Computer Burning Firmware Description File Description / 1.The main program is in the Marlin folder, you can use Arduino 1.8.5 version to open the Marlin.ino file to change the compilation and burning; 2. atmega1284p_bootloader.hex is the underlying bootloader of Ender-5 Pro motherboard, after the production line is burned with ISP cable, the firmware Ender-5 ProMarlin1.1.8EnglishTMC2208.hex can be directly burned through the USB interface of the computer Arduino; 3. Ender-5 ProMarlin1.1.8EnglishTMC2208.hex is the basic firmware of Ender-5 Pro, which must be atmega1284p_bootloader burned with ISP before the USB programming mode on the computer takes effect. 4. The first time you use ISP to burn Ender-5 ProMarlin1.1.8EnglishTMC22081284PBootloader.hex, the Ender-5 Pro firmware can be used, and the subsequent USB burning mode on the computer takes effect. Update firmware via USB from Adruino 1.8.5 on PC 1. Set up a 1284P and TMC2208 environment Download the Arduino software on the https://www.arduino.cc/en/Main/Software Installation Build the compilation environment of the 1284P motherboard / File → Preferences → Additional Boards Manager URLs: Add the 1284P environment configuration page https://raw.githubusercontent.com/Lauszus/Sanguino/master/package_lauszus_sanguino_index.json/ Tools → Boards: → Boards Manager Search for Sanguino and run Install In this way, the compilation environment of 1284P is set up Build U8gilb library function / Sketch → Include Library → Manager Libraries / Search for U8gilb and run Install So that the library function of U8gilb is set up Build the library function of the TMC2208 driver chip / Sketch → Include Library → Manager Libraries / Search TMC2208Steppe…

You’re welcome, afaik the split cable is the one that runs from the touch probe to the board, its usually one plug on the probe end and a split of 2 and 3 on the other end that goes into the board.

I would recommend using the files from the crealitycloud server as they have the correct files for your printer, the ones on the creality main website dont seem to include the default firmware your board has installed.

Yep it sounds like you have to have the default firmware installed on the printer to begin with and then use the USB lead and Arduino to flash the hex file to the printer along with the libraries as documented in the instructions.

Thank you but where do i find the hex file after i write the data?
Thats been a big problem as it shows written but then i dont know where it saves it.
So i cant load the flash.