Ender-5 Pro: Firmware on SD card not recognized


I recently bought a CR-Touch and installed it. It is already recognized by the Printer (the pin moves out 2 times on boot). I wanted to update the firmware to use it for my prints. I followed guides telling me to download the firmware (from CR Touch 3D Printer Parts - Creality 3D and choosing the “Ender-5 Pro CR Touch Firmware” and using the V4.2.2 board version, as it is my board.

Unfortunately, formatting the SD card with FAT(32) and 4096 Bytes, saving the firmware on there and inserting into the printer does not work. The printer boots up normally.

Can you tell me why the printer is not installing the firmware? What mistakes am I making?

My current Marlin version is 0.0.8, which it shipped with. Is that the problem?

What size SD card are you using ? The smaller the size the better, I have a few 8gb you I use just to do updates, as large sized SD cards dont work

1 Like

It’s a 2GB card, so it’s not too big

1 Like

The only file you should be placing on the SD card is usually the .bin file. If the file is not being read by the printer then you can also try renaming the firmware file to something like firmware.bin as that sometimes helps.

1 Like

Yes, I also tried renaming the firmware to “firmware.bin”, as I saw a filename length limit floating around in some forum posts, but still no luck…

I would recommend trying a different SD card just to be sure its not the card causing the issue.

I tried a new SD card and it finally worked! Thank you all for your answers!

1 Like

Glad to hear you found a working card :slight_smile: happy printing!

Good Evening,

What would be good is to know make model number of the sd card you brought to solve the problem Please