Ender 5 S1 not working properly

Has anyone else had a problem with the printer getting lost in the X-Y plane?My printer worked fine for about 6 weeks. Then one day about a half hour into a print it just quit. I was watching it when it quit. Nothing unusual happened when it quit. I tried printing it again and it kept going off the print bed during the auto leveling at startup and giving a probe error message. I was using their Sonic Pad. Thinking it was possibly the Sonic pad, I disconnected the Sonic pad and downloaded the firmware from Creality and tried to run it with the onboard controls. It made it through the self leveling at startup but when it started to print it went to the front left corner and tried to print the entire print in an area about 1 inch square. I had printed this trial object before with no problems and it should have printed in the center of the bed. I contacted Creality about the problem and uploaded the error file to Creality. They referred me to Geekbuying.com who has been giving me the runaround for about two months now. I sent them a video showing what was happening and their solution was to check the bed to see if it was warped. I am thinking it might be the main board but everybody seems to be out of stock, like their has been a run on main boards. That seems strange for a printer that has been out for less than a year.

Hi mate welcome to the forums

It seems hardware not software as you have already changed the firmware.

Have you checked all connections/belts etc make sure nothings come loose through vibrations