Ender3 v2 4.2.2 motherboard and BL Touch

Bought a BL Touch about a year ago for my Ender3 v2 and trying to figure out what firmware to use . It has a 4.2.2 motherboard and it’s plugged into the connector for it. I should add I’ve tried every download that has BL touch and Ender3 v2 4.2.2 .

I did get 2 firmwares to work yesterday . Level worked and it printed successfully .
Today is another story . It won’t level . What it does instead is go to 0x 0y ,move to center , go up 10mm , the BL Touch blinks a few times , stops blinking for a couple of seconds before continuing . All the while the screen says " Bed Leveling Please Wait Until Done " . I have left it blinking for over 2 hours . I’ve double-checked for loose connections and didn’t have any .

I don’t know what else to do .

Hello @Gerald-Leingang and Welcome to the Creality Forum…! :wave:Creality

I don’t know anything about the Ender 3 V2 but I did some checking to see what firmwares you could use. You might have already seen this page. Also before you do a firmware update try to set it back to factory defaults and see if that helps…

Ender 3 V2 Firmware download page

Printer: Ender-3 V2

Printer Mainboard: V4.2.2


The firmware is Ender-3V2 CR-touch/BL-touch version.

Display firmware update:

  1. Put the file “private、TJC_SET、DWIN_SET” into the TF card.

  2. Insert the TF card into the screen card slot.

  3. Restart the machine and wait for completion.

Mainboard firmware update:

  1. Put the firmware file “GD-Ender-3 V2-Marlin2.0.8.2-HW-V4.2.2-SW-V1.0.7_E_N_BLTouch.bin” into the root directory of TF card.

  2. Insert the TF card into the card slot of the printer.

  3. Reboot and wait for the update to finish.

Also this video might have some good info even though it’s not for the BL touch version:

I did install that firmware .I did trace my problem to my BL Touch .

On top of it ,there’s a small magnet that looks like a set screw . By raising it so it touches the adapter bracket , I cured my problems . It also changed the z axis offset to -3.00 mm .

That’s a lot of offset… Is it printing correctly now…?

It prints perfectly . About the z axis offset - my brother has the same printer with a CR Touch and he uses the same offset .