Falcon 2 Laser not finishing engraving/cutting via software but works fine via SD/TF Card

Hey guys, im kind of lost here, grinding 5 hours straight to fix my problem with the falcon 2. I received it today, when engraving or cutting, it just stops, there is no homecoming, no signals, nothing. I tried everything, pluged it into an other wall, used an other Computer, nothing helps. Then i wrote the Gcode on a SD-Card, and it just worked fine. What could be the problem? Also why is the beep sounds so loud? A neighbour called the house-caretaker not because of smoke from the laser, she called him because of the beeping, she was thinking there is an fire-alarm beeping…

Preciate your help, i really want to create some fantastic stuff !

What do you see on the console of Lightburn or LaserGRBL? Does it show a disconnect when it stops? If so, try a different USB-C cable.

thanks for your reply, it wasn the cable, i also tried 4 different usb-c cables, i tried usb-c and usb-a.
In fact it was the software, idk how, but it was an old version, and also not 64bit. When i updated it, everythink worked fine.
I really dont know how i got this older version it was something like. 0.5 or something, now everything is working, and im loving it! thx.