Ferret Windows Software Bug

I have Creality Scan 2.1.6 installed on a Windows 11 laptop with 16GB of RAM and dedicated nvidia graphics card. I have done several scans and they work well enough. However, if I try to use the select tool to pick portions of project to remove, the screen flashes then the object disappears completely and I can do nothing more. If I hit new scan, it takes me back to the settings page, then when I try to start the scan, there are no images from the camera and nothing actually scans. Once I restart the software, it works fine, unless I try to use the select/delete options.

I haven’t used mine much (Ferret Scan Pro) but it wasn’t doing that on my Window 10 Home version desktop with version 2.1.6. You would think that is enough memory…

Maybe reinstall it…??

You are having better luck than me with Windows 11. I am using Windows 11pro on a 2022 desktop with 16GB of RAM and a AMD Ryzen 7 5700G with built in Radeon Graphics and every time I try to scan with the 2.1.6 software and also previous 1.x.x software that is downloadable the software recognizes the scanner but never shows the cameras much like your secondary failure mode. At least you can get a scan. The computer can see all the cameras and all the permissions are set to allow the application to use them but I think that Windows11 has a security method that this software does not interface well with to access the camera. Support keeps sending me the same things to try with no success. I have reinstalled the software as admin as well with no change in operation. If anyone has something new to try I would sure love to hear it. I know the hardware can work as I got a partial scan from an Android tablet but it only has 3GB of ram so not too effective. I am in the process of upgrading my mobile Android phone to a 8GB newer Samsung 23FE to at least have one method to scan. I have the CR-scan ferret pro hardware. Oh I also got a older windows 10 laptop to work but being a bit slow the process and limitations are too great. Thanks for looking.

Thanks for sharing that info @EricZ and Welcome to the Official Creality Forum…!! :+1:

I wonder if sometimes virus software like Norton, McAfee or Kaspersky, etc can cause these issues if they are not configured correctly…?
Hmmmm… :thinking:

Not sure but I only use MS antivirus and turned if off briefly with no success. Regards

Have you looked at your Nvidia settings?
I know screen flashes almost always are GPU related issue’s.

I had to changed the Nvidia setting to use the GPU for graphic’s AND calculations to use the Hi-Quality setting of my Ferret Pro.

Working on W10 Pro (64bit) with Quadro P2200 with Creality Scan 2.3.5.

Hi!
I already saw you problem, I had this too a few days ago.
After checking and “hacking” around the drivers and lurking through the Crealitiy Scanner app I figured out some strange things.

  1. Your hardware drivers must be the original drivers from the hardware manufacturer.
    This mean, if you have a NVidia GPU then you must install that driver from NVidia and probably wont work with the MS crap driver.
    This is also for your motherboard too.
  2. When you start the scanner app and try to scan, try to use your settings with low quality scan. This can also help in your case to get the picture.
  3. Also a good think is to install PotPlayer and check your camera. The IR and the RGB camera should work.

I also checked the app on an i3, i5, i7 10th gen. cpu with ss usb but never got a usable FPS rate if I enabled the HQ scanning mode.

I also recognized does if the app is only started, even without a camera attached it consumes very much cpu power, I didn’t found out the reason for now.
This is happening with all 3 versions of the app which are downloadable from the Creality web site.

If you can test too, does the app is eating up your cpu power and post about this, I would really appreciate.

I also contacted Creality but nobody is responding for now.

My best regards.
Chris.

1 Like

Hi Chris,

Thanks for the info and work you have done trying to determine things about running with Windows11.

First I am currently running a Ryzen7 5700G CPU (3.8 GHz) with built in AMD Radeon graphics and it does have the latest driver from AMD, I even tried the clean up software for Radeon they pointed too in one of the Creality troubleshooting links but it made no difference. I do not have a second graphics card installed.

I still need to try some of your other suggestions but I did open the scan app with no scanner attached and my CPU utilization was 8%-9% with the software sitting idle which does seem like more than I would expect for being idle and looking for the hardware.

Will post again when I have a chance to try some other things.

Thanks,

Eric