K1 MAX Slicer Software Crashes when slicing

K1 MAX software continues to crash when slicing. I have used this several times for 4-6 months. In the last week all of the sudden I cannot slice a model without the software crashing about 10% into the slice. Consistently same spot every time and with different models?

Have you updated your slicer in the last month or so, I used to have that with bigger models but the latest update fixed it

Hello @Gearrunner and Welcome to the Official Creality Forum…!

Maybe another recently installed software is causing a conflict…

Try to reinstall Creality Print and see if that helps.

In the past few days a new version of Creality Print was released. I would recommend testing with the latest version if you have not already done so…

Creality Print 4.3.8

@Nikoli Just curious… I wonder why the update checker in Creality Print on my PC doesn’t show this update. Are they waiting to make sure this update is stable… I haven’t updated yet… I’m still on :eyes:

Have you used the newest version and is it an improvement…?

I have to be honest @jimandyen I am not sure. Originally it was put out as a kind of BETA but within a day or so was promoted to a release version. The release was primarily to go in conjunction with the release of the K1C in China. (4.3.8 has K1C profiles :wink: )

And yes I have used the latest version and find it smoother, more stable and slightly faster.

I’ll update it from Github then… I hope it takes care of @Gearrunner crashing issue… :+1:

1 Like

Yep fingers crossed it resolves any underlying issues users may have been having :slight_smile:

I went and updated the Creality Print software from github (V4.3.7 to V4.3.8)

Checked it out and sliced a file which took about 5 minutes. I thought that was a little too long so went back and installed V4.3.7. Sliced the same file and settings in 2 minutes… Of course your mileage may vary and I’ll check again but for now I’ll stay on this version.

Yes I have u installed and re installed latest software and previous version’s. I still crash on multiple models when I slice.

Out of curiosity what are the specs of the pc you are trying to slice on? and if your happy to please feel free to share one of the stl’s that is causing the crash when you slice so that we could also test on our machines for you.


I have used these STL files before so they should not be corrupt? However I tried to copy an stl file to this post and it will not let me do so.Like I said before I had no problems until about a week ago and then it started happening. I have printed several items prior to this?

Thanks for sharing your specs, looking at them shows that you really should not be limited performance wise.

Sorry to hear you were unable to upload the STL, if its on a public site by all means post a link to the file and I will be more than happy to test for you to compare results.

Oftentimes it can be silly things like Windows updates or Windows component updates which cause issues with other softwares, I would certainly love to get to the bottom of this issue though.