K1 max xy position outside build plate

Just revived my K1 max printer and have issues at first setup. The printer head wants to move outside the build plate in xy direction. When performing the auto leveling process the nozzle is actually outside the build plate on the right side.

When the head moves out the edges the whole printer starts to shake just beacons the head wants to move further than the mechanical stop.

Do any one have an idea how to fix this? Is it a software issue or a hardware issue?
Firmware version: V1.3.0.39


@Tunnan Could you please provide a video of the auto-leveling?

Of course, please see Dropbox link.


Motherboard problem, need to replace the motherboard.

Please contact after-sales customer service.

Thank you, I’m currently waiting for their answer.

I had this same problem after replacing the motherboard on my K1 Max. Turns out it is actually the driver_SGTHRS setting for the sensorless homing. It’s set too high (aka too sensitive) on one of the drivers (on mine it was stepper_x that was too high) - this means that the printer thinks that the toolhead is already at the max position. This messes with the position the printer thinks it is at, which puts the position for zero outside of the bed.

The only way to fix it would be for Creality to allow some access to the printer config files, since it’s a built-in configurable feature of Klipper. If you can’t get to that setting the printer will always home incorrectly unless that flag can be changed.

Thank you for sharing. Have you solved your issue? And how did you do it in that case?


I have now replaced the motherboard and it solved the problem.

1 Like