K1C smart filament detection module

Hi all,
have any of you managed to replace the built-in filament sensor with one that monitors the filament movement? Too many failed prints due to filament jams. I mean something like the brand new Bigtreetech SFS V2.0. If yes, what wiring?

1 Like

I have it working with an ender3v3 for some time now. If the K1C is similar:

On the printer side one of the wires is marked with a white plastic clip. I have this connected to the green wire (movement detector), the middle wire to black and the remaining to red.

In the printer.cfg the new config is

[filament_motion_sensor filament_sensor]
detection_length: 5.0
extruder:extruder
pause_on_runout: true
switch_pin: ^PC15
runout_gcode:
  M118 Filament runout/blocked!

1 Like

Thanks. I’ve already ordered the Bigtreetech SFS, I will give a try to your settings as soon as I get it

Hi, I just finished testing your settings and the wiring you recommended and I can tell you that everything works perfectly. Thanks again :ok_hand:

1 Like

Just so I understand…You have this sensor working on the K1C? I bought one and intend to install it when I get the nerve to tear into it.
On the K1C do how do you access the mother board?
Thanks,
Glenn

Yes, it’s working fine on a K1C,
Only the movement sensor, to be precise, but if the filament ends-up, will be detected as “not moving” and the printer get in pause.
You don’t need to access the motherboard in order to connect the new sensor.
I just unplugged the old one and swapped the wires with the ones from Bigtreetech SFS V2.0, like Herman said.
Here’s a picture I took


I used a female connector and soldered the SFS wires in the correct order.
After that, I modified the printer.cfg file deleting the two sections starting with “[filament_switch_sensor filament_sensor]” and “[filament_switch_sensor filament_sensor_2]” and adding the lines Hermann wrote before.
Ps. The first line control the former sensor I removed. The second line looks like being related to a filament sensor mounted directly to the extruder, maybe as a future hardware upgrade, Actually looks like unused and if you leave it, it cause a printer error.

Okay, this is making more sense to me now, thanks to you all.
One more question, how do I access the printer.cfg file?
Is it on the printer or somewhere on my computer?

Regarding the second runout sensor, check this article out.
K1 Extruder Filament Runout Sensor by Henlor | Download free STL model | Printables.com

Thanks for the link about the estruder filament sensor, now it make more sense to me.
Printer.cfg file is located on printer OS filesystem. So you need to access the printer filesystem in order to edit the file.
I tried to access the file using a remote file browser such us FileZilla or Cyberduck but I had no luck at all.
The only way for me was through a terminal window, via SSH. If you have a mac or a Linux machine, just type the lines below in the built-in terminal, if you have windows, you can use Putty, or similar.

ssh root@your_local_printer_IP_address (for logging-in to the printer.)
password is: creality_2023

cd /usr/data/printer_data/ config (for accessing the folder where printer.cfg is located)

ls (for listing the files)

Thank you for that :slight_smile: Does this mean I need to “Root” the printer first?

I got to the printer but it is not accepting that password.

Maybe you have a different root password.
You can read root password from printer settings menu.
From the home screen, select the gear icon and scroll down to “Root Account Information.” Once there, wait 30 seconds before tapping “OK.” The screen will display information on root access,

1 Like

Hi, I’m trying this many times, and unfortunately everytime printer can’t work. Write “Error Key: 3002; Unknow exception.” Can do that link from outset of printer.cfg to [virtual_pins] and [include sensorless.cfg] where is write set [filament_switch_sensor filament_sensor]“ and „[filament_switch_sensor filament_sensor_2] too? I know something I do wrong but…

Hi, that’s my working printer.cfg
Hope it helps
printer.cfg

1 Like

Hi, everyones
I want realy very much thanks to Dario for help with his version printer.cfg By compared his and my file I’m find diferent write, because my K1C have more things “rooted”. Here is writen in head my printer.cfg diferent
[virtual_pins]
[include sensorless.cfg]
[include gcode_macro.cfg] *
[include printer_params.cfg]
[include Helper-Script/timelapse.cfg]
[include Helper-Script/M600-support.cfg] *
[include Helper-Script/save-zoffset.cfg]
[include Helper-Script/useful-macros.cfg] *
[include Helper-Script/fans-control.cfg]
[include Helper-Script/nozzle-cleaning-fan-control.cfg]
[include Helper-Script/KAMP/KAMP_Settings.cfg]
So I was browsed every files write in “include” And delete every mention about [filament_switch_sensor filament_sensor_2] and change every mention [filament_switch_sensor filament_sensor] to [filament_motion_sensor filament_sensor] by Darios.
Only after these changes printer working right without problems and errors. I thx again Dario. :wink:
PS: * = This next files I’m edited, if these help anyone.

1 Like