Making the 427 board work on the CR-10 S5


I got the CR-10 S5 and bought the BL touch autoleveling kit.
My printer appears to have the 2.1 board which does not have an easy way to attach the BL touch.
So I gave up on installing it onto this board. Instead I bought the 427 board with ender 3 firmware.

I attached most of the wires but I am not sure where to attach:

  • the fans (got 2 case fans and the extruder fan, but there are only two sockets)
  • the filament sensor (this is unreliable anyway)

Which firmware do you recommend?

I already built Marlin 2.1 but before burning I would like to fetch the original firmware. Can I do that with stm32flash? how? I cannot get a connection.

Thank you very much


As far as I am aware the 4.2.7 board is not officially supported by the CR-10 printers. Partly due to lack of connectors on board for some components but also you would usually require a completely different screen to work with the 4.2.7 board.

Screen works fine, you have to use the 3rd connector. It’s exactly the same board.

You may be able to locate a firmware here:
BL Touch Auto Leveling Kit

ah, the first file is not a firmware but an overview. someone should make that clear o.O

how do I get the firmware onto the board?

Yes the first file in the list documents which versions should be used with different versions of the board.

To flash the firmware you would usually place the bin file onto an SD card formatted as FAT32 with 4096 allocation units. Insert the SD into the printer and power on.

Seems to have worked. Still shows the Ender logo, but also shows CR10 now.
Thank you very much. Going to figure out the rest as well and report back.

1 Like

You’re welcome! Yep you will likely find that the Ender logo is baked in to the chip on board. Glad to hear you were able to get the firmware flashed :slight_smile:

The new CR10 427 firmware worked somehow, but had wrong dimensions (smaller than 500x500) and I did not find out how to calibrate auto leveling. (ie height difference between probe and hotend)
I connected both Hotend fans to the controlled fan sockets. But they can only be controlled together. Should I connect one of these to permanent power?

I installed self-built marlin 2.2.x. initially there was a lot wrong about axis’ and end-stops, but now most of the hardware seems to work.
The ender logo isn’t hard wired. I expected I had installed the Creality logo, but it shows marlin logo.

I just cannot figure out how to use autoleveling UBL. It just does nothing. (less than the stock firmware)

Found a guide: Unified Bed Leveling | Marlin Firmware

With stock firmware UBL works. But as soon as I start printing, the head runs down endlessly. have to switch off.

with custom marlin, UBL does not work at all as it does not move the z axis.

Had to set it to:
//#define Z_MIN_PROBE_PIN -1

Now the extruder doesn’t extrude. 8)
negative values are for retracting, positive for extruding?
It seems to run in a virtual wall before anything leaves the extruder. the motor just doesn’t continue running…

It looks like you are making some progress.

In terms of the extruder, yes I would expect that a positive value would be extrude and a negative value would be retract.

Thanks. It works now.
I will publish my config in the Marlin-Config-Repo on config/examples/Creality/CR-10 S5/CrealityV427-BLTouch/
Somehow the command to test the bed leveling does not work. As shown in the guide I tried

G26 C P5.0 F3.0

But it does not extrude any material. This is why I tried to figure out what is wrong with the extruder. Maybe Cura gives higher flow speed than what the printer believes is correct. So Cura works but the above command doesn’t.

Glad to hear progress is going well.

As far as I know by default the G26 command is not enabled in the config.

If you uncomment the following line in the config files it should then work.

I already enabled it. It tries to do something but it does not extrude any (or enough) material while doing this.

The command above assumed 3 mm filament which was wrong.

Hope your getting somewhere with it now