Massive issues after Sprite Extruder Pro Upgrade on Ender 3

Dear all, I am using an Eder 3 and decided to replace the original printhead with a Sprite Extruder Pro Kit.
I installed and wired it. Also settings for E Steps where set to the 424.9 and retraction was adjusted to 0.8 like in the manual.
I also leveled the bed.
But my first prints failed. The first layers are not flat, the nozzle stucks and detaches the print from the bed. I have no idea what that could be or how I could fix that. I share some photos - maybe you have an idea. I use cura for slicing. The bed is leveled (as good as I can) and cleaned with isopropanole. The nozzle is new - as the old one scratched the bed.

I am thankful for any idea.

Hi all,

are there any special settings for cura? Can I change the E steps? At the Hotend itself there is nothin I can adjust - right?
I just started another print - seems like the first layers the noozle scratches over the printed surface - at about 2mm it lifts up more and then there is a clear print.
Could it me a mechanical issue? could there be an issue with the Z axes?

On the photo you see the issues on the lowest levels - and then a gap from where on it all is smooth …

I really have no more idea.

From the pictures, it’s clear that the nozzle is too close to the platform and it’s obviously compressed the layer.

Re- leveling:
Reference video:

Thanks Collin.
Thought I levelled it - but I will do again.
Also will check screws and movement of Z axis.

Will also replace the glass of the bed - think it‘s not the best.

Will send an update.

Dear Collin,

another topic - maybe you have an idea for that too.

I have a bl-touch installed.
When I try auto - level the mesh does not fit my printer bed - as the original printhead was replaced?
I have a 4.2.7 mainboard installed. How can I “readjust” the mesh so that I can run the auto bed leveling?

Thanks for an hint.

Hi Experts - I just re leveled the bed. the 1st 1 - 2 Layers really look good - but then something strange habens. at about 0.6 - 0.8 mm the Z axis does not move up - the display shows a 0.2 step in Z but the motor seems not to turn. Then the scratching over the surface starts.

Then - magic - at 2mm - there is a real “jum” in Z axis - from then the levels look good - no scratching
But that causes a “gap” to the first levels and no clear wall.
I’m not sure if you can follow my description. I never saw that issues. Any idea? I did not fis the Z axis screws to much - so the Z axis should not “stuck”.

any idea is highly welcome!!

I think it worked. Level adjusted, z axis checked. Screws checked. The z step looks good and that 2mm „jump“ has gone - not sure what exactly fixed it.

Sprite Extruder Pro Installation Video

I hope this helps.

Go to this reddit post…… Help with CR touch with Sprite Extruder Pro kit for Ender 3 V2. Google it It’ll come up. You need to install professional firmware and then adjust various settings. The settings are all listed in the post. It worked for me

Hi all, I could fix it by replacing the glass of my bed and with adjusting the flow and the axis screws. For now all is fine. Thanks for your comments.