Need firmware updates but in English

I correctly installed the firmware update on my e3 v3 se, unfortunately, now my screen is now i think in Chinese and I cannot figure out how to change the language to English.

In addition, the printer runs very slow and changing velocity has no effect.

Is there a firmware update in English so I can attempt to figure out the issue?

Hi @SKIP_L_Goebel and welcome to the forums.

There seems to be an odd glitch with the 1.0.6 SE firmware and the language.

One known fix is to try the following…

Download the firmware files from the website E3 V3 SE - Firmware Download.
Extract the contents of the zip file.
Rename Ender-3 V3 SE_HWCR4NS200320C13_SWV1.0.6_GD303.bin to Firmware.bin
Copy the Firmware.bin file to your SD card.
Insert the card in to the printer and power on.
Once complete power off the printer and remove the SD card and delete any files left on the card if necessary.

If the issue still persists please try updating the screen firmware using a Micro SD card as follows…
Insert the Micro SD card into your computer and format as FAT32 and allocation size of 4096.
Copy the only the TJC_SET folder and its contents to the Micro SD card.
Insert the Micro SD card into the side of the screen and power on the printer.
Once updated power off the printer, remove the Micro SD card and power on the printer again.
If no improvement try re-flashing the motherboard firmware again after updating the screen.

If all else fails flash back to the original firmware and the language should return to normal.

Good luck and hope that helps.

When that happened to me i used google translate live translate with the camera to find the language selection and change it back to english.

Glad to hear you were able to set the language back ok. Feel free to share the steps involved in changing the language back such as which option to pick etc as others might find it helpful :slight_smile:

it worked, however, i am waaay over extruding now.
what is the proper e-steps for the se extruder?

1 Like

Glad to hear the re-flashing worked out for you.

I am unsure what the default esteps of the SE is but here is a link to the Creality Calibration tutorial so that you can double check everything it correct…

Creality Print Calibration Tutorial

Hope that helps :slight_smile:

I’ve got the same issues. The V1.0.6 update for the Ender 3 V3 SE now works perfectly for me.
After many inconclusive tests, only the firmware 1.0.6 downloaded on the following link works for me :

At startup, the screen appears fine with the choice of 11 languages as at the first startup with the OEM version.

thanx
ill give it a try

1 Like