New Firmware released!

They did it!

A firmware update has been pushed that enables setting the root password, you can see instructions here:

Files, instructions, and recovery :smiley:

I’ve tried to instal the new firmware on my motherboard, but it was failing. I’ve realized that the firmware size was too small. Maybe something wrong with it I’ve also tried to install the recovery software, but it doesn’t open on my Windows11 laptop.

did you get the file from the github site? Creality’s github repo?

It seems that a few days ago they’ve changed the github download.

I have 3 USB drives ready to go (yeah, I back up my back-ups, lol) but as of now, I prefer to wait.
Reason: There are a lot of programmers and otherwise creative folks out there that are way smarter than me! Until I feel I can hold a candle to them, I will read, learn, experiment, and use choice swearwords when required.
I’m trying to learn 3 diff languages including forscan (not for printing but for my truck) but I work as a commercial construction contractor and time is never on my side, lol.
Things are working though, not at the level I need, yet, but, I use too many commas, my poor aching head can’t keep up, so good enough is ok, for now. It’s like hunting: Do everything you can control so that when you pull the trigger, the desired outcome becomes the result!

And I finally finished this…

What is that…? Some kind of video or audio display. Lots of lights. Cool… :star_struck:

It’s a spectrum analyzer. Responds to sounds, columns are diff frequencies of sound within the audible range, 20-20000hz.

Nice project. I’m impressed. Looks good…