Objects have a seam at the left side

When I print an object with my KC1 (eg a sphere) there is always a seam at the left side. Ugly, I never get a smooth object, whatever I try and set. How can I solve this? All other faces are rough but ok.

Hi JanP

This is caused by your slicer settings.
If you are using Creality Print, before slicing click edit, then Shell and look at Z seam alignment and Seam Corner Preference.
There are a few options but not having really printed a sphere I cannot say which to use. Worth trying a few options to see what works for you.

Good luck