Problem with Falcon 2 40w not registering on laptop

Been using Falcon 2 40w for 2 weeks without any serious problems. Today I downloaded templates from a website and tinkered with the settings such as speed and power and then closed down for dinner break. On return the falcon does not register on my laptop (running Windows 11). I have tried turning falcon and laptop off and resetting both. Still no luck. A hammer is the next thing on my list but I understand that both I fragile. Any suggestions of alternatives to try please? I am an octogenarian but reasonably tech savvy. Any help would be appreciated.

Hi @DaveGu welcome to the forums.

I have not used the Falcon myself but one thing you could check is Right Click on the Start Menu button and select Device Manager, check that there are not yellow triangles/exclamation marks on any of the related devices. If there are you should be able to right click on them and select update driver to resolve it. Another fix can often be to uninstall the problematic device, reboot windows and re-connect the device to initiate the driver install.