Replacement bearings

Hi. Can anyone tell me a source where I can get a replacement bearing for my gantry for my Falcon2 40W? I tried the official Creality store but have not had any luck.

Thanks in advance.

Just so I understand correctly…

Moving parts are the motor themselves and the wheels on the carriage.
…unless I’m forgetting something! :open_mouth:
I presume you a speaking about the wheels?

Yes, the wheels. Creality got back to me and are in the process of sending me a new wheel. Hopefully this solves my issue.

1 Like

OK! Glad you got it sorted out.

Is the wheel in real bad shape? Just curious no how/why it got broken…

I also saw them going pretty cheap on the internet - places like eBay, Amazon, Alibaba, …

Let us know how it turned out!

Hi Zolt. Thanks for the message. Not sure what happened to the wheel. I assume it was a manufacturing defect as the machine is new. Received the replacement wheels today and that seemed to fix the problem. However, I seem to have a new problem (or one that I didn’t notice before). If you can see the attached videos the machine seems to grab as it moves along the y axis. The machine is square and I tried loosening the tension on the belts but it did nothing to solve the problem. Any help would be greatly appreciated as I have still not been able to use the machine yet.

Hey GregB!
Glad one problem is solved…too bad a new one appeared.
I can’t open the video for some reason.
I unfortunately don’t know what else you could try - I’ve never shared a video before…

Could you inspect the belt(s) to see if there is anything wrong with it like a missing teeth?

Hi Zolt.

I had a hard time compressing the files. Hope this works. The belts look good for what I could tell. P

lease let me know if you can’t see this or if you can hopefully you can give me some advice.


Yep - that is weird indeed.

One thing for sure is that you shouldn’t have to go through all this on a brand new unit!

OK - that being said…If you want to continue the troubleshooting by yourself, let’s take this a step at a time…but I’d still try to contact either Creality or the vendor you bought it from while trying to figure it out!

First thing is to ensure all cables are sitting tight in the connectors and that no pin bent or broken. It seems to be an issue on some devices and it’s an easy thing to check.

Now that the cables have been checked, try this. On the rod that goes left-right behind the front panel, you’ll see 2 cogwheels on either end. They have 2 hex screw to tighten them on the rod. Ensure they are not loose. You shouldn’t use excessive pressure when screwing these, but enough so they don’t slip under normal operation.

If this wasn’t the issue either, you can try the following: loosen both cogwheels enough so they move freely. Now, put a small piece of masking tape somewhere on the rod so that it goes all around it - it can have wrinkles which will help. Using the front panel buttons, move back/forth with your finger on the piece of masking tape to feel if there is any skipping, which could indicate a defective motor.

Other than that, I’m out of ideas for now.

Let me know how it went and if you found the issue.

Hi Zolt. Thanks for all of your help so far.
Screen shot of materials test
I purchased my machine directly from Creality. I have reached out to them but unfortunately I need to wait 5 more days until after their holidays. In the meantime I figured I would try a materials test in lightburn to see if I can dial in my settings. Unfortunately I ran into other issues. In the attached image there are a few problems. The laser is not cutting squares but rectangles with a cut in the bottom right corner (highlighted in red). The issue is more noticeable when you look at the smaller materials test located to the right. Also, the writing is illegible (highlighted in blue). Any thoughts on this? Thanks.

This really looks like something loose to me.
I can’t think about anything…except maybe loose diode/mirror, but believe me, you don’t want (and shouldn’t) go play in that area.

Really sorry I can’t help more. I’m really clueless.

You’ll have to wait for Creality to come back from holiday I guess.
Really curious on what they’ll say!

Good luck, and please keep us posted!