[solved] Start the fan for PLA from the 1st layer?

Hi everyone !
Whatever slicer I used (namely Cura or Prusaslicer), I can’t get the printer (ender 3 v2 neo) to run the fan cooling 100% right at the start of the 1st layer.
I suppose I could get this running from the gcode (M106 S255 i think ?) but I would like this setup to remain specific to PLA (I’m a lot more used to PETG/Wood).
Any things I might have overlook please ?

PS : also, I’ve recently update my Ender 3 v2 neo with the firmware 1.1.7. Now, in Control / Info menu, I see now that I’m under the 1.1.7 firmware, and there’s an indication for the bed size with 220x220x250 ?? How come ?

Hi @mediaklan

If you wish to enable the fan for the first layer you can do the following…
PrusaSlicer: In Filament Settings select Cooling and then set “Disable fan for the first:” to 0.
Cura: In the Cooling section of the profile settings you should see “Regular fan speed at height” and “Regular fan speed at layer”. Adjust these to your preference.

In regards to the bed size in the info menu… my guess is that they may use either the same firmware or same mainboard but on multiple machines so have specified the bed size to ensure the machine knows what size the bed should be.

Hope that helps :slight_smile:

1 Like

Hi Nikoli
Thanks for your answers. I’ve already tried the settings you point out (thank you anyway, always a good reminder), but this fan won’t start either way. I’m guessing I have a configuration either in Octoprint or the slicer that creates interference. I know the fan works since I can run it from octoprint or mattercontrol just fine. I will continue to look into it.
My bed size is supposed to be 235x235. If I move the hotend to the far right, I can see it reached 220. If i move back ther hotend to the far left, it reaches … -13 ^^´
It’s not too much of an issue, but I believe Creality should really step up their game regarding firmwares. And an updated procedure. With rollback and fallback procedure. But that’s an entire different stoy ^^’

You’re welcome @mediaklan
In PrusaSlicer you may also need to disable “Enable auto cooling” and you may also need to set “Full fan speed at layer” to 1 to force the fan to come on.

If the printer you have is the Ender 3 V2 Neo then your print area is 220x220x250mm. The build plate will be 235x235mm as it allows for extra tolerance when printing with brims, skirts or support structures.

I am actually preferring the way the firmwares are done nowadays as it means that multiple models of printers are more likely to receive updates all in one go at the same time rather than them having to make one for each specific machine which causes delays in being able to release them :slight_smile:

1 Like

Finally, an answer that actually makes sense for the bed size. The seller actually said it was a mistake. Thanks ! That clarifies it.
For the firmware updates, I was not talking about the management on Creality side, I was referring to the way it is delivered to the end-user. But it’s OK. In the end, using a 3d printer is the way of tinkering things, so maybe the end-user needs to step up his game too.
Thanks again for your answers.

1 Like

I am so glad I was able to help you with the bed sizing issue :slight_smile:

It does get confusing as when the X axis homes to the far left that is effectively its 0 position but in terms of the printable area of the bed its approx -13 away. Therefore when the printer is told the bed is 220 it knows to move the printhead in by at least 13 to ensure its on the print bed :slight_smile:

It’s confusing at first but when you watch the printer home its axis and then move to the printing position you will notice the printhead always goes to the far left (its 0 position) when homing but then sits approx 13 in from its 0 position to be above the print surface :slight_smile: the 220x220 is then mapped out starting from the 13 position onwards.

I really hope that all actually makes sense :joy:

Ahhh I see what you mean regarding the firmware now… I take it that the Ender 3 V2 Neo still updates via the SD card? The newer printers now receive the updates directly from the internet which is a really nice feature that I hope continues going forward as its as easy as “There is an update”, tap the update button and done :slight_smile:

Glad to help out :slight_smile:

1 Like